• twitter image
  • facebook image
  • youtube image
  • linkedin image
Language: CMS Made Simple Czech CMS Made Simple France CMS Made Simple Spain CMS Made Simple Hungary CMS Made Simple Russia CMS Made Simple Netherlands

All times are UTC




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: Why default file set on content_image not appearing?
PostPosted: Sat Oct 14, 2017 1:53 am 
Offline
Forum Members
Forum Members

Joined: Thu Feb 07, 2008 10:28 pm
Posts: 112
What would be the reasons why the default image I've set for my content_image tag is not appearing?

Code:
{content_image block='hero_image' label='Hero Image' urlonly='1' exclude='thumb_' dir='images/parallax' assign='hero' default='default.jpg'}

<img class="parallax-background-img" src="{$hero}" alt="{title}" />


I've tried absolute URLs but it just shows up empty. I know I'm missing something really small and stupid but I've been stuck on this for a few days now.

Any insight would be greatly appreciated, thank you.


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Why default file set on content_image not appearing?
PostPosted: Sat Oct 14, 2017 11:00 am 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Wed Apr 23, 2008 7:53 am
Posts: 7442
Location: The Netherlands
System info?

_________________
Image

Did my post help you solving a problem at your (customers) website and it saved you many hours of work? Great!! Consider buying me a cup of coffee in return! [ Click here ]



Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Why default file set on content_image not appearing?
PostPosted: Sun Oct 15, 2017 7:02 pm 
Offline
Power Poster
Power Poster
User avatar

Joined: Fri Apr 18, 2008 9:34 pm
Posts: 314
Location: Nimbin, Australia
from plugin help:
Quote:
Note: As of version 2.2, if this content block contains no value, then no output is generated.
which seems to contradict the info for default
Quote:
(optional) default (string) - Use to set a default image used when no image is selected.


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Why default file set on content_image not appearing?
PostPosted: Mon Oct 16, 2017 5:36 am 
Offline
Forum Members
Forum Members

Joined: Thu Feb 07, 2008 10:28 pm
Posts: 112
Rolf wrote:
System info?


Thank you Rolf for your time. Here is my system info, I'm noticing that the assign property isn't working all that well altogether...

Code:
----------------------------------------------
Cms Version: 2.2.3.1
Installed Modules:
AdminSearch: 1.0.4
CGSimpleSmarty: 2.1.7
CMSContentManager: 1.1.6
CmsJobManager: 0.1.1
DesignManager: 1.1.3
FileManager: 1.6.4
FilePicker: 1.0.1
LISE: 1.3.1
LISECityActivities: 1.3.1
LISECitySponsors: 1.3.1
LISEGalleries: 1.3.1
LISEMarketing: 1.3.1
LISEParallax: 1.3.1
LISESidebar: 1.3.1
LISESlider: 1.3.1
LISESponsors: 1.3.1
LISEVideo: 1.3.1
MenuManager: 1.50.3
MicroTiny: 2.2.1
ModuleManager: 2.1.2
Navigator: 1.0.8
News: 2.51.3
Search: 1.51.2
TinyMCE: 3.2-beta3

Config Information:
php_memory_limit:
max_upload_size: 15000000
url_rewriting: mod_rewrite
page_extension:
query_var: page
auto_alias_content: true
locale:
set_names: true
timezone: America/Los_Angeles
permissive_smarty: false

Php Information:
phpversion: 7.0.22-0ubuntu0.16.04.1
md5_function: On (True)
json_function: On (True)
gd_version: 2
tempnam_function: On (True)
magic_quotes_runtime: Off (False)
E_ALL: 22527
E_STRICT: 0
E_DEPRECATED: 0
test_file_timedifference: A discrepancy in time with the PHP environment was detected. This may cause problems when publishing i.e. news articles.
test_db_timedifference: No time difference found
create_dir_and_file: 1
memory_limit: 192M
max_execution_time: 30
register_globals: Off (False)
output_buffering: 4096
disable_functions:
open_basedir:
test_remote_url: Success
file_uploads: On (True)
post_max_size: 8M
upload_max_filesize: 15M
session_save_path: /var/lib/php/sessions (1733)
session_use_cookies: On (True)
xml_function: On (True)
xmlreader_class: On (True)
check_ini_set: On (True)
curl: On

Performance Information:
allow_browser_cache: On (True)
browser_cache_expiry: 60
php_opcache: On (True)
smarty_cache: Off (False)
smarty_compilecheck: Off (False)
auto_clear_cache_age: On (True)
Server Information:
Server Software: Apache/2.4.18 (Ubuntu)
Server Api: fpm-fcgi
Server Os: Linux 4.4.0-96-generic On x86_64
Server Db Type: MySQL (mysqli)
Server Db Version: 5.7.19
Server Db Grants: Found a "GRANT ALL" statement that appears to be suitable

Permission Information:
tmp: /sc/site/stage2.amgentourofcalifornia.com/public/tmp (0775)
tmp_cache: /sc/site/stage2.amgentourofcalifornia.com/public/tmp/cache (0775)
templates_c: /sc/site/stage2.amgentourofcalifornia.com/public/tmp/templates_c (0775)
modules: /sc/site/stage2.amgentourofcalifornia.com/public/modules (0775)
uploads: /sc/site/stage2.amgentourofcalifornia.com/public/uploads (0775)
File Creation Mask (umask): /sc/site/stage2.amgentourofcalifornia.com/public/tmp/cache (0775)
config_file: 0464
----------------------------------------------


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Why default file set on content_image not appearing?
PostPosted: Mon Oct 16, 2017 1:22 pm 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Wed Apr 23, 2008 7:53 am
Posts: 7442
Location: The Netherlands
Quote:
Rev 11518 2017-10-15 15:53:54
Author: calguy1000
Log message:
Fix to handling of default parameter for {content_image} block.

Looks like a bug in core, and already fixed in SVN
Will be shipped in upcoming 2.2.4 release we are now testing.

Grtz. Rolf

_________________
Image

Did my post help you solving a problem at your (customers) website and it saved you many hours of work? Great!! Consider buying me a cup of coffee in return! [ Click here ]



Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
A2 Hosting