CMS Made Simple Forums
https://forum.cmsmadesimple.org/

Server Umzug Problem
https://forum.cmsmadesimple.org/viewtopic.php?f=24&t=19558
Page 1 of 2

Author:  Erbsenroller [ Fri Feb 15, 2008 2:55 pm ]
Post subject:  Server Umzug Problem

Hallo Zusammen,

ich habe nach einem Server Umzug folgendes Problem. Layout, Menü etc. wird nicht mehr angezeigt. Folgende Fehlermeldungen:

string(132) "Smarty error: [in preview:cmspreviewKogCwn line 10]: syntax error: unrecognized tag 'metadata' (Smarty_Compiler.class.php, line 583)" string(134) "Smarty error: [in preview:cmspreviewKogCwn line 11]: syntax error: unrecognized tag 'stylesheet' (Smarty_Compiler.class.php, line 583)" string(136) "Smarty error: [in preview:cmspreviewKogCwn line 13]: syntax error: unrecognized tag 'cms_selflink' (Smarty_Compiler.class.php, line 583)" string(136) "Smarty error: [in preview:cmspreviewKogCwn line 14]: syntax error: unrecognized tag 'cms_selflink' (Smarty_Compiler.class.php, line 583)" string(136) "Smarty error: [in preview:cmspreviewKogCwn line 15]: syntax error: unrecognized tag 'cms_selflink' (Smarty_Compiler.class.php, line 583)" string(134) "Smarty error: [in preview:cmspreviewKogCwn line 60]: syntax error: unrecognized tag 'cms_module' (Smarty_Compiler.class.php, line 583)" string(134) "Smarty error: [in preview:cmspreviewKogCwn line 63]: syntax error: unrecognized tag 'cms_module' (Smarty_Compiler.class.php, line 583)" string(135) "Smarty error: [in preview:cmspreviewKogCwn line 72]: syntax error: unrecognized tag 'breadcrumbs' (Smarty_Compiler.class.php, line 583)" string(138) "Smarty error: [in preview:cmspreviewKogCwn line 77]: syntax error: unrecognized tag 'global_content' (Smarty_Compiler.class.php, line 583)" string(136) "Smarty error: [in preview:cmspreviewKogCwn line 86]: syntax error: unrecognized tag 'cms_selflink' (Smarty_Compiler.class.php, line 583)" string(136) "Smarty error: [in preview:cmspreviewKogCwn line 95]: syntax error: unrecognized tag 'cms_selflink' (Smarty_Compiler.class.php, line 583)" string(136) "Smarty error: [in preview:cmspreviewKogCwn line 96]: syntax error: unrecognized tag 'cms_selflink' (Smarty_Compiler.class.php, line 583)" string(139) "Smarty error: [in preview:cmspreviewKogCwn line 111]: syntax error: unrecognized tag 'global_content' (Smarty_Compiler.class.php, line 583)"

Was kann ich tun?

Zusätzlich sagt mir die Module-Übersicht, dass der Modul-Ordner schreibgeschützt sei obwohl ich es auf 777 gesetzt habe. Ich nehme an, dass es etwas damit zu tun hat, dass das alte System in einem Subordner auf dem Server lag (also www.domain.de/cms/) im neuen System allerdings unter dem Stammverzeichnis läuft.

Vielen Dank für die Hilfe,
Erbsenroller

Author:  cyberman [ Fri Feb 15, 2008 3:20 pm ]
Post subject:  Re: Server Umzug Problem

Da stimmen die Pfade nicht - check das mal.

Hast du den Cache gelöscht?

Author:  Erbsenroller [ Fri Feb 15, 2008 3:29 pm ]
Post subject:  Re: Server Umzug Problem

Hallo Cyberman,

die Pfade unter config.php? Wenn ich versuche, den Cache zu löschen zeigt er an Das Cache-Verzeichnis ist nicht beschreibbar. Das Leeren des Caches wird daher nicht funktionieren. Bitte stellen Sie sicher, dass das Verzeichnis tmp/cache die vollen Lese-/Schreib- und Ausführungsrechte hat (chmod 777). obwohl ich auf dem Server das TMP Verzeichnis komplett auf 777 gesetzt habe.

Gruß,
Erbsenroller

Author:  groove [ Fri Feb 15, 2008 3:36 pm ]
Post subject:  Re: Server Umzug Problem

Hallo Erbsenroller

Hatte gerade das selbe Problem. Umzug von 5 Seiten - bei 4 hat es problemlos funktioniert bei der 5ten hat es gekracht. Schätzte daher das igendetwas bei der Installation aus dem Ruder gelaufen ist.
Wir haben nach einigem erfolglosem Rätselraten einfach CMCMC neu installiert und die Inhalte importiert und dann war alles am Laufen. Ich denke das wird der schnellste Weg sein;-)

gruß
groove

Author:  Erbsenroller [ Fri Feb 15, 2008 3:46 pm ]
Post subject:  Re: Server Umzug Problem

Hi Groove,

wie hat Du das denn gemacht? Das CMSMS auf einem blanken Server installiert und dann? Ich habe bestimmt 200 Seiten, wie kann ich diese Inhalte (upgeloadete Bilder etc.) denn importieren?

Erbsenroller

Author:  groove [ Fri Feb 15, 2008 3:49 pm ]
Post subject:  Re: Server Umzug Problem

Mit den files wirst du denke ich kein problem haben - es geht rein um die Datenbankinhalte. Wir haben die Files mitsamt ihrer Ordnerstruktur einfach wegkkopiert und nacher wieder hineinkopiert. An den relativen Pfaden zu den Bildern und sonstigen Dateien ändert sich ja nichts.

Author:  Erbsenroller [ Fri Feb 15, 2008 3:53 pm ]
Post subject:  Re: Server Umzug Problem

Ok, also Neuinstallation, dann die Module neu installieren und die Bilderordner hochladen und dann über den MySQL Admin die inhalte importieren?! :-\

Gruß,
Erbsenroller

Author:  groove [ Fri Feb 15, 2008 4:31 pm ]
Post subject:  Re: Server Umzug Problem

so haben wir es gemacht  :)

Author:  cyberman [ Fri Feb 15, 2008 5:43 pm ]
Post subject:  Re: Server Umzug Problem

Erbsenroller \Erbsenroller:
Ok, also Neuinstallation,


Du kannst auch den Installations-Assistenten noch einmal durchlaufen lassen, musst nur die config.php leeren und im Schritt 4 das Erzeugen der Tabellen und Schreiben der Inhalte deaktivieren. Der Assistent findet zuverlässig die neuen Pfade ...

Author:  Erbsenroller [ Tue Feb 19, 2008 3:15 pm ]
Post subject:  Re: Server Umzug Problem

Das hat schonmal geklappt. Neuinstallation ohne Erzeugen von neuen Tabellen. Wunderbar. Vielen Dank an Cyberman und Groove  ;D Allerdings komme ich jetzt nicht mehr in den Admin Zugang rein. Er wirft mir folgende Meldung aus: Parse error: syntax error, unexpected $end in /www/htdocs/w00881ee/modules/FrontEndUsers/lang/en_US.php on line 521 Diese Zeile existiert aber gar nicht, das File hört bei 520 auf  ???

Erbsenroller

Author:  Erbsenroller [ Tue Feb 19, 2008 3:40 pm ]
Post subject:  Re: [Gelöst]Server Umzug Problem

Hab die Datei einfach mal umbenannt - jetzt komme ich rein  ;D Es muss aber doch noch irgendwo auf diese Zeile verwiesen werden?!

Author:  NaN [ Tue Feb 19, 2008 4:33 pm ]
Post subject:  Re: [Gelöst]Server Umzug Problem

Da scheint ein Fehler in der Datei zu sein. Ist zum Glück nur die Sprachdatei. Hat also keinen Einfluss auf die Funktionalität.

Zum Fehler:
In der Datei werden dem Array $lang einfach nur verschiedene Indizes mit zugehörigen Werten zugewiesen.
(also z.B. $lang['user'] = "Benutzer"; )
Nichts weiter.
Damit kann CMSms den Text in der eingestellte Sprache anzeigen.
Irgendwo fehlt wahrscheinlich ein Semikolon am Ende einer Zeile. Oder Es fehlt ein Anführungszeichen. Oder vielleicht ist auch irgendwas zu viel. Ist bestimmt nur ein kleiner Tippfehler der Entwickler. Der PHP-Parser "denkt" nun, die Zeile sei nicht korrekt beendet worden und erwartet demzufolge noch irgendetwas. Das vermutlich in der nächsten Zeile stehen sollte... So, oder so ähnlich. Die PHP-Fehlermeldungen sind manchmal recht knifflige Ratespielchen aus denen man nie so richtig schlau wird. Meistens können mehrere völlig verschiedene Ursachen zu ein und derselben Fehlermeldung führen.

Welche Version des FrontEndUsers-Modul verwendest Du?

Author:  Erbsenroller [ Wed Feb 20, 2008 10:47 am ]
Post subject:  Re: Server Umzug Problem

Da legst Du den Finger genau auf die Wunde  :P Habe gerade versucht das Modul neu zu installieren, da die alte version nicht mehr richtig zu funktionieren scheint. Allerdings verzwirbelt mir das gleich das ganze Admin System. Ich bekomme bei hochladen der XML folgenden Fehler

Fatal error: Call to undefined function: restrictunknownparams() in /www/htdocs/w00881ee/modules/FrontEndUsers/FrontEndUsers.module.php on line 322

Zusätzlich geht mir irgendwie das Stylesheet vom Adminbereich flöten --> kein 'Layout' mehr sondern nur noch aufeinenderfolgende Zeilen mit den einzelnen Menüpunkten  ???

Ich kann das Modul auch nicht mehr löschen oder ihm über FTP die Rechte für den Ordner ändern ??? Nur noch umbenennen funktioniert und dann ist der Adminbereich wieder OK. Nur wie kann ich jetzt die Verzechnisse wieder löschen? Das ist so eigenartig, also ob noch von irgendwo darauf verwiesen wird und ich deswegen nicht löschen oder neu installieren kann.

Habe es jetzt mehrmals auf dem FTP-Server probiert. Ich kann weder die Rechte ändern noch löschen. Weder einzelne Dateien, noch ganze Ordner. Was zum Kuckuck ist denn da jetzt los? Ich fühle mich in meiner Macht als Administrator beschnitten!!!  ::)

Was tun?

Author:  Erbsenroller [ Wed Feb 20, 2008 3:03 pm ]
Post subject:  Re: Server Umzug Problem

...zusätzlich bekomme ich auch bei jeder neu erstellten Seite oder Aktion innerhalb des Adminsystems eine Fehlermeldung vom Internet Explorer

The XML response that was returned from the server is invalid

Wenn ich die Anzeige ignoriere wird der Vorgang aber nach einem Refresh (F5) trotzdem ausgeführt.

Hilfe

Author:  cyberman [ Wed Feb 20, 2008 5:47 pm ]
Post subject:  Re: Server Umzug Problem

Erbsenroller \Erbsenroller:
Diese Zeile existiert aber gar nicht, das File hört bei 520 auf  ???


Welche Version verwendest du?

Hab gerade mal in der aktuellen, deutschen Übersetzung nachgesehen - die hat 635 Zeilen ...

Page 1 of 2 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/