GELÖST: nach Update auf 1.7.1: Glossary meldet Fehler im default_encoding

Hilfe zur Installation
Post Reply
mw1972
Forum Members
Forum Members
Posts: 79
Joined: Mon Apr 21, 2008 12:07 pm

GELÖST: nach Update auf 1.7.1: Glossary meldet Fehler im default_encoding

Post by mw1972 »

wie es scheint greift das Modul Glossary auf einen Wert default_encoding des CMS zurück, den es so in der Version 1.7.1 nicht mehr gibt.

Auf der Seite http://www.kiga-maeusenest.de/elterninfo/faq/ sieht man die Fehlermeldung

Ein Blick in php Datei Glossary.module.php zeigt die Stellen

Code: Select all

$entrySize = count($starts);
      for ($i=0;$i<$entrySize;$i++)
         {
         if ($i > 0 && $i % 2 ==0)
            {
            if ($difLen > 1)
               {
               $difLen--;
               }
            }
         else
            {
            $difLen = 1;
            }
         $flet = '';
         $llet = '';
         while ($flet == $llet && $difLen < $spining_chars)
            {
            if (mb_strlen($starts[$i]) >= $difLen)
               {
               $flet = mb_substr($starts[$i],0,$difLen,$config['default_encoding']);
               }
            if ($i + 1 < $entrySize && mb_strlen($starts[min($i+1, $entrySize-1)]) >= $difLen)
               {
               $llet = mb_substr($starts[min($i+1, $entrySize-1)],0,$difLen,$config['default_encoding']);
               }
            $difLen++;
            }
         $starts[$i] = mb_substr($starts[$i],0,$difLen - 1,$config['default_encoding']);
         }
Last edited by mw1972 on Mon May 31, 2010 6:20 pm, edited 1 time in total.
mw1972
Forum Members
Forum Members
Posts: 79
Joined: Mon Apr 21, 2008 12:07 pm

Re: nach Update auf 1.7.1: Glossary meldet Fehler im default_encoding

Post by mw1972 »

Problem gelöst.

Bei mir was in der config.php folgendes:

#In almost all cases, default_encoding should be empty (which defaults to utf-8)
#and admin_encoding should be utf-8.  If you'd like this to be different, change
#both.  Keep in mind, however, that the admin interface translations are all in
#utf-8, and will be converted on the fly to match the admin_encoding.  This
#could seriously slow down the admin interfaces for users.
$config['default_encoding'] = '';
$config['admin_encoding'] = 'utf-8';


In meinem Fall musste der default_encoding Wert eben nicht wie oben beschrieben leer sein, sondern eben auch mit utf-8 belegt sein.
cyberman

Re: nach Update auf 1.7.1: Glossary meldet Fehler im default_encoding

Post by cyberman »

Ist nach meiner bescheidenen Meinung ein Fehler in der Programmierung - hast du schon eine Fehlermeldung im Forge abgesetzt?
Post Reply

Return to “Installation und Einstellungen”