• twitter image
  • facebook image
  • youtube image
  • linkedin image
Language: CMS Made Simple Czech CMS Made Simple France CMS Made Simple Spain CMS Made Simple Hungary CMS Made Simple Russia CMS Made Simple Netherlands

All times are UTC




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: anyone tried using CloudFlare with CMSMS? [solved]
PostPosted: Sat Jul 30, 2011 2:53 am 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Thu Nov 22, 2007 10:41 pm
Posts: 85
Location: Canada
My apologies if I've posted in the wrong forum group, but nothing else seemed to be appropriate for this topic.

With Google's latest "Page Speed Test" (http://www.webpagetest.org) that was just announced/released, I happened across CloudFlare (http://www.cloudflare.com).

I'm wondering if anyone in the CMSMS community has tried this out with a CMSMS site, and if they ran into any troubles.

I've tried one with the latest version (1.9.4.2) but I seem to keep getting an error message when trying to edit a page.

The error message I get is:
\$1:
Error: the xajax Javascript component could not be included. Perhaps the URL is incorrect?
URL: ../lib/xajax/xajax_js/xajax_core.js


I've checked on the URL and it is actually correct, I'm just suspecting there's some conflicting script or something.


Last edited by geepers on Tue Aug 02, 2011 5:27 pm, edited 1 time in total.

Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: anyone tried using CloudFlare with CMSMS? [solved]
PostPosted: Tue Aug 02, 2011 4:54 pm 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Thu Nov 22, 2007 10:41 pm
Posts: 85
Location: Canada
Update - I found this post on hosting multiple domains on CMSMS (http://forum.cmsmadesimple.org/viewtopic.php?t=22890).

I should note that I'm running CMSMS v1.9.4.2

So, I've altered the config.php file, changing the following values:
\$1:
#Document root as seen from the webserver.  No slash at the end
#If page is requested with https use https as root url
#e.g. http://blah.com
$config['root_url'] = 'http://mydomain.com';

#SSL URL.  This is used for pages that are marked as secure.
$config['ssl_url'] = 'https://mydomain.com';


to this

\$1:
#Document root as seen from the webserver.  No slash at the end
#If page is requested with https use https as root url
#e.g. http://blah.com
$config['root_url'] = 'http://' . $_SERVER['HTTP_HOST'];

#SSL URL.  This is used for pages that are marked as secure.
$config['ssl_url'] = 'https://' . $_SERVER['HTTP_HOST'];


This allows me to access the admin section of my site using the default bypass domain specified in the CloudFlare account (the default is 'direct.mydomain.com'.

This appears to be working for me. I'll update this post should any other problems arise.


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: anyone tried using CloudFlare with CMSMS? [solved]
PostPosted: Sun Aug 28, 2011 5:38 pm 
Offline
New Member
New Member
User avatar

Joined: Sun Oct 14, 2007 8:38 am
Posts: 9
Location: Zuidhorn, Netherlands
I'm using CloudFlare as an experiment for about a week now on a main domain and a subdomain.

CloudFlare really makes a difference. The increase in speed is remarkable.

A few days before reading this post I added a section in the Wiki about Using CMSMS with CloudFlare. I think it will explain how to fix the problems you have with accessing the admin section without having to resolve to using SSL.

I hope this helps,
regards,
Ron Wardenier

Edit on 2012-12-03: The Wiki entry seems to have been removed from the CMSMS site. I stopped using CloudFlare by mid September 2011 since it cached static content only and introduced all kinds of DNS trouble seriously harming the uptime.


Last edited by warden on Mon Dec 03, 2012 8:51 pm, edited 1 time in total.

Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: anyone tried using CloudFlare with CMSMS? [solved]
PostPosted: Tue Sep 27, 2011 9:42 am 
Offline
Forum Members
Forum Members

Joined: Tue Sep 13, 2011 6:02 am
Posts: 96
using it too and very happy indeed!


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Hosting Nation - Managed CMSMS Hosting