• twitter image
  • facebook image
  • youtube image
  • linkedin image
Language: CMS Made Simple Czech CMS Made Simple France CMS Made Simple Hungary CMS Made Simple Russia CMS Made Simple Netherlands

All times are UTC




Post new topic This topic is locked, you cannot edit posts or make further replies.  [ 4 posts ] 
Author Message
 Post subject: <textarea> tag not showing in browser
PostPosted: Fri Oct 12, 2018 11:41 am 
Offline
Forum Members
Forum Members

Joined: Wed Aug 08, 2018 4:59 pm
Posts: 31
I pasted a form to the <source code> in the content manager.

But the <input> tags are only showing but not the <textarea> tag.

It is almost like the editor is somehow skipping the tag after I paste it to the <source code>. (please see attachment)

Attachment:
File comment: here is a pic that shows the &nbsp; that appears were the <textarea> should be.
notextarea.PNG
notextarea.PNG [ 3.58 KiB | Viewed 476 times ]


Can someone explain to me why this is happening and is there a solution to this.


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: <textarea> tag not showing in browser
PostPosted: Fri Oct 12, 2018 1:24 pm 
Offline
Forum Members
Forum Members
User avatar

Joined: Fri Dec 09, 2005 12:36 pm
Posts: 231
Location: Marlow, UK
Assuming you're using TinyMCE (or MicroTiny) ... some older versions of the editor would strip empty tags. So if there's nothing in your textarea to start with that might be the problem.

It's working fine for me here in the latest version though. You should try making sure you're up to date and then try with some placeholder content in the textarea.


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: <textarea> tag not showing in browser  Topic is solved
PostPosted: Fri Oct 12, 2018 2:15 pm 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Wed Feb 25, 2009 4:25 am
Posts: 716
Location: Victoria, BC
It's also a good idea to not use WYSIWYG on html-heavy pages. Good options are to either disable wysiwyg for that page, or put the form in a generic template and just put the template call in the content instead:
Code:
{include file='cms_template:myformtemplate}


The latter makes it harder for users to accidentally mess up the form, too.

_________________
Not getting the answer you need? CMSMS support options


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: <textarea> tag not showing in browser
PostPosted: Tue Oct 16, 2018 12:18 pm 
Offline
Forum Members
Forum Members

Joined: Wed Aug 08, 2018 4:59 pm
Posts: 31
Thank you both for the info. I have everything working as it should now


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
Display posts from previous:  Sort by  
Post new topic This topic is locked, you cannot edit posts or make further replies.  [ 4 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Hosting Nation - Managed CMSMS Hosting