CMS v1.1.2 Captcha Non WebRoot Install Error

A place to discuss the testing process in beta cycles or against SVN for the CMS Made Simple CORE package.
Locked
apmuthu

CMS v1.1.2 Captcha Non WebRoot Install Error

Post by apmuthu »

CMS v1.1.2 on http://www.domain.com/cmsmadesimple/
Captcha v0.3
FormBuilder v0.4.1

Installed all the above in that order on a BlueQuartz-CentOS (NuOnce BQ 4.6) server running
PHP v5.2.3
MySQL v5.0.27

Created a form using FormBuilder and enabled Captcha protection. The captcha gets generated but he image does not display as the img src is wrong. The current image path will be correct only if CMS was installed in http://www.domain.com itself instead of http://www.domain.com/somefolderpath/.

Current Workaround is to replace the following lines 527 and 528 in modules/Captcha/lib/hn_captcha/hn_captcha.class.php

Code: Select all

         if($onlyTheImage) return "\n".'<img class="captchapict" src="'.$this->get_filename_url().'" '.$is[3].' alt="This is a captcha-picture. It is used to prevent mass-access by robots. (see: www.captcha.net)" title="">'."\n";
         else return $this->public_key_input()."\n".'<img class="captchapict" src="'.$this->get_filename_url().'" '.$is[3].' alt="This is a captcha-picture. It is used to prevent mass-access by robots. (see: www.captcha.net)" title="">'."<br />\n";

with

Code: Select all

         if($onlyTheImage) return "\n".'<img class="captchapict" src=".'.$this->get_filename_url().'" '.$is[3].' alt="This is a captcha-picture. It is used to prevent mass-access by robots. (see: www.captcha.net)" title="">'."\n";
         else return $this->public_key_input()."\n".'<img class="captchapict" src=".'.$this->get_filename_url().'" '.$is[3].' alt="This is a captcha-picture. It is used to prevent mass-access by robots. (see: www.captcha.net)" title="">'."<br />\n";


Observer the period (.) after the src="
Locked

Return to “[locked] Quality Assurance”