Module Manager should only show the latest and stable version of modules

A place to discuss the testing process in beta cycles or against SVN for the CMS Made Simple CORE package.
Locked
RonnyK
Support Guru
Support Guru
Posts: 4963
Joined: Wed Oct 25, 2006 8:29 pm
Location: Raalte, the Netherlands

Module Manager should only show the latest and stable version of modules

Post by RonnyK »

I was thinking that the Module Manager should only show one version per module, being the latest/stable. If some users want pre-releases or whatever they are called, he/she could download them from the dev-area. MM should however not propose to install them, as most users want modules to work out-of-the-box.

Ronny
calguy1000
Support Guru
Support Guru
Posts: 8169
Joined: Tue Oct 19, 2004 6:44 pm
Location: Fernie British Columbia, Canada

Re: Module Manager should only show the latest and stable version of modules

Post by calguy1000 »

Yeah, ModuleManager (and it's partner ModuleRepository) need work.
Personally I think that all of the modules of the same name should be grouped together, ideally in a neat ajaxy tree type thing so that only the latest version was shown by default, and there was some kind of an 'expand' link to show other versions.

Additionally, it should only show versions that are theoretically compatible with your current version of CMS.  I don't think this happens currently (and I wrote it :)

TSW found a neat ftp class that'd allow installing of all modules via ftp (supply an ftp host, username, password, directory) and everything gets uploaded via ftp.  this would be a cool way of doing it too.  it'd solve problems encounered by noob users who don't have knowledge about permissions, usernames, groups, umasks and all that nice stuff (even though they should).

Another method of solving these permissions issues may be to just have some hooks that 'blow open permissions' before a module is installed, and 'restores them' afterwards.....

Just my thoughts.
Follow me on twitter
Please post system information from "Extensions >> System Information" (there is a bbcode option) on all posts asking for assistance.
--------------------
If you can't bother explaining your problem well, you shouldn't expect much in the way of assistance.
Locked

Return to “[locked] Quality Assurance”