• twitter image
  • facebook image
  • youtube image
  • linkedin image
Language: CMS Made Simple Czech CMS Made Simple France CMS Made Simple Spain CMS Made Simple Hungary CMS Made Simple Russia CMS Made Simple Netherlands

All times are UTC




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: Article: Installation > Clean Urls
PostPosted: Fri Sep 30, 2005 6:50 am 
Offline
Translator
Translator

Joined: Sat Mar 12, 2005 12:30 pm
Posts: 169
Location: Vienna
If you want to to use clean URL's like something.shtml and not index.php?page=something then

go on reading

Step 1

Copy file htaccess.txt from Your /doc directory to Your webroot and rename it to '.htaccess'

Step 2


Make sure there is line "$config['assume_mod_rewrite'] = true;" in Your /config.php file

Thats it now you have cleen Url's in your address

Was it not simple


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Article: Installation > Clean Urls
PostPosted: Thu Mar 09, 2006 10:20 am 
But how htaccess the file is to read?
Much-calibrated so:

\$1:
RewriteEngine on
RewriteRule ^seite_(.*).html$ index.php?page=$1


Please help!


Top
   
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Article: Installation > Clean Urls
PostPosted: Tue Apr 18, 2006 6:41 pm 
No, it WAS NOT SIMPLE he he...  ???  :-\  ::)  :o

I have no problem with clean URLs as you can see here and the .htaccess to this looks like this:

\$1:
php_flag magic_quotes_gpc Off
php_flag register_globals Off
php_flag session.use_trans_sid Off

# Make sure you have Options FollowSymLinks
# and Allow on
RewriteEngine On

#Rewrites page.shtml as index.php?page
RewriteCond %{REQUEST_FILENAME} !-f [NC]
RewriteRule ^(.+)\.html$ index.php?page=$1 [QSA]


But on my subdomain i got an HTTP 404 error (it works fine now) and the .htaccess was exactly the same:

\$1:
php_flag magic_quotes_gpc Off
php_flag register_globals Off
php_flag session.use_trans_sid Off

# Make sure you have Options FollowSymLinks
# and Allow on
RewriteEngine On

#Rewrites page.shtml as index.php?page
RewriteCond %{REQUEST_FILENAME} !-f [NC]
RewriteRule ^(.+)\.html$ index.php?page=$1 [QSA]


In both examples the config.php file have these values:

\$1:
$config['assume_mod_rewrite'] = true;
$config['page_extension'] = '.html';


So after my hair had grown long into the machinery (me and my computer are now one unit) i wrote that i could try to use this:

\$1:
RewriteBase /


So, for my subdomain on exactly the same server, i take the .htaccess file and put this RewriteBase / in just before the RewriteCond %{REQUEST_FILENAME} !-f [NC] so it looks like this:

\$1:
php_flag magic_quotes_gpc Off
php_flag register_globals Off
php_flag session.use_trans_sid Off

# Make sure you have Options FollowSymLinks
# and Allow on
RewriteEngine On

#Rewrites page.shtml as index.php?page
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f [NC]
RewriteRule ^(.+)\.html$ index.php?page=$1 [QSA]


...and now it works..!

Server info:

Apache/2.0.51 (Fedora)
PHP Version 4.3.10


Sincerely
Nano


Last edited by Nanochild on Sun May 07, 2006 5:32 pm, edited 1 time in total.

Top
   
 
Share On:
Share on Facebook Share on Twitter Share on Google+
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Hosting Nation - Managed CMSMS Hosting