• twitter image
  • facebook image
  • youtube image
  • linkedin image
Language: CMS Made Simple Czech CMS Made Simple France CMS Made Simple Spain CMS Made Simple Hungary CMS Made Simple Russia CMS Made Simple Netherlands

All times are UTC




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: Japanese characters in alias
PostPosted: Mon Jan 18, 2010 7:32 am 
Offline
Forum Members
Forum Members

Joined: Thu Jul 09, 2009 8:35 am
Posts: 17
I'm not sure if this is a bad way to do it. I'm just posting this here.

in lib/misc.functions.php in function munge_string_to_url

...snip...

This is how I like my URLs. This may only work with "pretty URLs"/mod_rewrite. Full-width and normal spaces are replaced by a minus. Then all other punctuation and non-kanji/kana/roman characters minuses and underscores are discarded.

...snip...

Let me state once more, that I'm not sure if this breaks anything or even generates valid URLs.

In anyone has any comments or corrections, I'd be very interested to hear them.

Many thanks!


Last edited by calguy1000 on Thu Nov 11, 2010 11:13 am, edited 1 time in total.

Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Japanese characters in alias
PostPosted: Mon Jan 18, 2010 9:48 am 
Offline
Forum Members
Forum Members

Joined: Sun Jul 05, 2009 2:37 am
Posts: 86
thanks for that!!
I'll try it and let you know.


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Japanese characters in alias
PostPosted: Sat Jan 23, 2010 12:07 am 
Offline
Forum Members
Forum Members

Joined: Sun Jul 05, 2009 2:37 am
Posts: 86
tested this and it works great so far!
I'll keep you up to date with any issues.
many thanks
Ben


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Japanese characters in alias
PostPosted: Sat Jun 26, 2010 2:00 pm 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Tue Oct 19, 2004 6:44 pm
Posts: 8144
Location: Fernie British Columbia, Canada
Modifying your CMSMS install means you will not receive ANY support.
I'm keeping a list,

_________________
Follow me on twitter
Please post system information from "Extensions >> System Information" (there is a bbcode option) on all posts asking for assistance.
--------------------
If you can't bother explaining your problem well, you shouldn't expect much in the way of assistance.


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Japanese characters in alias
PostPosted: Thu Nov 11, 2010 10:07 am 
Offline
Forum Members
Forum Members

Joined: Sun Jul 05, 2009 2:37 am
Posts: 86
Hi Calguy,

Of course I understand that this is the case.
However, please consider the reasons that the hack has been done.
I.e. that utf-8 characters are an integral part of urls as used in many sites around the world, and for my site we can't live without them.
See my post here" http://forum.cmsmadesimple.org/index.ph ... 746.0.html

I would like you to consider including support for utf-8 characters (at least as an option) in a future version.

Best regards

Ben


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
A2 Hosting