• twitter image
  • facebook image
  • youtube image
  • linkedin image
Language: CMS Made Simple Czech CMS Made Simple France CMS Made Simple Hungary CMS Made Simple Russia CMS Made Simple Netherlands

All times are UTC




Post new topic Reply to topic  [ 8 posts ] 
Author Message
 Post subject: Notice: Module CGBlog not found in memory.
PostPosted: Mon May 20, 2019 11:53 am 
Offline
Power Poster
Power Poster
User avatar

Joined: Thu Mar 23, 2006 9:25 am
Posts: 1836
Location: The Netherlands
CGBetterforms wilde geen scan doen op een formulier en ging bij 'scan' meteen terug naar overzicht van beschikbare templates. Wellicht een upgrade nodig? Voor zowel CGBetterforms als CGExtension was er een update. Deze geladen en in het moduleoverzicht allemaal meldingen dat modules een upgrade nodig hadden en dat er afhankelijkheden waren van ander modules die ook een upgrade nodig hadden. De 'upgrade-knop' in het module overzicht leek weinig effect te hebben.

Cache geleegd, uitgelogd en toen....helaas:
Quote:
Notice: Module CGBlog not found in memory. This could indicate that the module is in need of upgrade or that there are other problems in /Users/gjdegraaf/Sites/admin/moduleinterface.php on line 54


CMSMS versie is 2.2.10

Kan er dus helemaal niet meer in. Wat te doen?


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Notice: Module CGBlog not found in memory.
PostPosted: Mon May 20, 2019 3:14 pm 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Wed Apr 23, 2008 7:53 am
Posts: 7662
Location: The Netherlands
Clear cache?

_________________
Image

Did my post help you solving a problem at your (customers) website and it saved you many hours of work? Great!! Consider buying me a cup of coffee in return!



Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Notice: Module CGBlog not found in memory.
PostPosted: Mon May 20, 2019 3:54 pm 
Offline
Power Poster
Power Poster
User avatar

Joined: Thu Mar 23, 2006 9:25 am
Posts: 1836
Location: The Netherlands
Had ik al gedaan, maar zonder resultaat. Cookies ook verwijderd, maar dat bood ook geen soelaas.


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Notice: Module CGBlog not found in memory.
PostPosted: Mon May 20, 2019 4:49 pm 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Wed Apr 23, 2008 7:53 am
Posts: 7662
Location: The Netherlands
Je hebt PHP7.2 op de server? De CG modules hebben dat sinds kort als vereiste.

_________________
Image

Did my post help you solving a problem at your (customers) website and it saved you many hours of work? Great!! Consider buying me a cup of coffee in return!



Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Notice: Module CGBlog not found in memory.
PostPosted: Tue May 21, 2019 10:53 am 
Offline
Power Poster
Power Poster
User avatar

Joined: Thu Mar 23, 2006 9:25 am
Posts: 1836
Location: The Netherlands
Rolf wrote:
Je hebt PHP7.2 op de server? De CG modules hebben dat sinds kort als vereiste.
Nee, 7.1.6 draait op mijn Mac. Zal kijken of en hoe ik een upgrade kan doen. Lijkt binnen OS X Mojave niet 1-2-3 gedaan.

In zijn algemeenheid vraag ik me wel af, als een bepaalde PHP-versie een vereiste is, waarom controleert de bouwer daar niet vooraf in de programmatuur op en een melding geeft binnen Modulemanager; er vinden tenslotte ook controles op onderlinge afhankelijkheden plaats. Dit zou m.i. ook een onderdeel van het testen van een module behoren te zijn: wat als de omgeving van de gebruiker niet aan de voorwaarden voor het kunnen uitvoeren van een module voldoet.

Maar goed, eerst zien of ik de upgrade erop krijg, want ik thans nergens bij noch dat ik het vanuit de admin kan herstellen.


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Notice: Module CGBlog not found in memory.
PostPosted: Fri May 24, 2019 1:47 pm 
Offline
Power Poster
Power Poster
User avatar

Joined: Thu Mar 23, 2006 9:25 am
Posts: 1836
Location: The Netherlands
Het was een klus, maar PHP 7.2.18 draait op Mojave's localhost en alle modules kunnen upgraden.

Helaas is het probleem van CGBetterforms daarmee niet opgelost. Een form openen en dan op 'scan' of 'save' drukken brengt je direct terug naar het overzicht van de aanweizige forms. De admin log geeft geen meldingen daaromtrent.

Enig idee?

Quote:
----------------------------------------------
Cms Version: 2.2.10
Installed Modules:
AceEditor2: 1.05
AdminSearch: 1.0.4
CGBetterForms: 1.9.5
CGBlog: 1.15.8
CGContentUtils: 2.3
CGExtensions: 1.62.9
CGFeedback: 2.2.1
CGSimpleSmarty: 2.2.1
CGSmartImage: 1.22.5
CG_RSS_Reader: 1.0.4
CMSContentManager: 1.1.7
Captcha: 1.0
CmsJobManager: 0.1.3
DesignManager: 1.1.6
ExaExternalizer: 0.6
FileManager: 1.6.8
FilePicker: 1.0.4
Gallery: 2.3.2
Gbook: 2.2.6
HitCounter: 2.1.2
JQueryTools: 1.4.2
MenuManager: 1.50.3
MicroTiny: 2.2.4
ModuleManager: 2.1.6
Navigator: 1.0.9
News: 2.51.5
Search: 1.51.6
SitemapMgr: 1.5.4
TemplateExternalizer: 2.1.6
UpUtils: 0.2.1

Config Information:
php_memory_limit: 128000000
max_upload_size: 2000000
url_rewriting: mod_rewrite
page_extension:
query_var: page
auto_alias_content: true
locale:
set_names: true
timezone: Europe/Amsterdam
permissive_smarty: true

Php Information:
phpversion: 7.2.18
md5_function: On (True)
json_function: On (True)
gd_version: 2
tempnam_function: On (True)
magic_quotes_runtime: Off (False)
E_ALL: 32767
E_STRICT: 2048
E_DEPRECATED: 8192
test_file_timedifference: No time difference found
test_db_timedifference: No time difference found
create_dir_and_file: 1
memory_limit: 128000000
max_execution_time: 30
register_globals: Off (False)
output_buffering: 4096
disable_functions:
open_basedir:
test_remote_url: Success
file_uploads: On (True)
post_max_size: 8M
upload_max_filesize: 2M
session_save_path: /var/tmp (1777)
session_use_cookies: On (True)
xml_function: On (True)
xmlreader_class: On (True)
check_ini_set: On (True)
curl: On

Performance Information:
allow_browser_cache: Off (False)
browser_cache_expiry: 60
php_opcache: On (True)
smarty_cache: Off (False)
smarty_compilecheck: Off (False)
auto_clear_cache_age: On (True)
Server Information:
Server Software: Apache/2.4.39 (Unix) PHP/7.2.18
Server Api: apache2handler
Server Os: Darwin 18.6.0 On x86_64
Server Db Type: MySQL (mysqli)
Server Db Version: 8.0.11
Server Db Grants: Could not find a suitable "GRANT ALL" permission, this does not necessarily lead to problems... But if you have problems installing/removing modules or adding and deleting items/pages this could be the cause!

Permission Information:
tmp: /Users/xxxx/Sites/tmp (0755)
tmp_cache: /Users/xxxx/Sites/tmp/cache (0755)
templates_c: /Users/xxxx/Sites/tmp/templates_c (0755)
modules: /Users/xxxx/Sites/modules (0755)
uploads: /Users/xxxx/Sites/uploads (0755)
File Creation Mask (umask): /Users/xxxx/Sites/tmp/cache (0755)
config_file: 0644
----------------------------------------------


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Notice: Module CGBlog not found in memory.
PostPosted: Fri May 24, 2019 4:54 pm 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Wed Apr 23, 2008 7:53 am
Posts: 7662
Location: The Netherlands
Het je het "server" error log ook geraadpleegd? Of het JS console van de browser. Kan je leiden naar een PHP of een JS fout, ik vermoed het laatste eigenlijk. Clear browser cache ook maar even doen...

CGBetterforms zelf ken ik verder niet.

_________________
Image

Did my post help you solving a problem at your (customers) website and it saved you many hours of work? Great!! Consider buying me a cup of coffee in return!



Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Notice: Module CGBlog not found in memory.
PostPosted: Fri May 24, 2019 5:12 pm 
Offline
Power Poster
Power Poster
User avatar

Joined: Thu Mar 23, 2006 9:25 am
Posts: 1836
Location: The Netherlands
In de server error_log komen geen meldingen. Caches zijn allen geleegd. Als ik in de access_log kijk vanaf het moment dat ik op 'scan' druk, dan krijg ik het volgende terug:
Quote:
fe80::1%lo0 - - [24/May/2019:19:02:52 +0200] "GET /admin/themes/OneEleven/css/default-cmsms/images/ui-bg_highlight-soft_75_fa8004_1x100.png HTTP/1.1" 200 344
fe80::1%lo0 - - [24/May/2019:19:02:52 +0200] "GET /admin/themes/OneEleven/css/default-cmsms/images/ui-icons_ffffff_256x240.png HTTP/1.1" 200 6299
fe80::1%lo0 - - [24/May/2019:19:02:54 +0200] "GET /admin/themes/OneEleven/css/default-cmsms/images/ui-icons_147fdb_256x240.png HTTP/1.1" 200 4549
fe80::1%lo0 - - [24/May/2019:19:02:54 +0200] "POST /admin/moduleinterface.php HTTP/1.1" 302 -
fe80::1%lo0 - - [24/May/2019:19:02:54 +0200] "GET /admin/moduleinterface.php?mact=CGBetterForms,m1_,defaultadmin,0&__c=45c464119d7e6913be1 HTTP/1.1" 200 27638
fe80::1%lo0 - - [24/May/2019:19:02:55 +0200] "GET /lib/jquery/js/jquery-1.11.1.min.js HTTP/1.1" 200 95786
fe80::1%lo0 - - [24/May/2019:19:02:55 +0200] "GET /lib/jquery/js/jquery-ui-1.10.4.custom.min.js HTTP/1.1" 200 228539
fe80::1%lo0 - - [24/May/2019:19:02:55 +0200] "GET /lib/jquery/js/jquery.mjs.nestedSortable.js HTTP/1.1" 200 13982
fe80::1%lo0 - - [24/May/2019:19:02:55 +0200] "GET /lib/jquery/js/jquery.json-2.4.min.js HTTP/1.1" 200 2259
fe80::1%lo0 - - [24/May/2019:19:02:55 +0200] "GET /lib/jquery/js/jquery-migrate-1.2.1.min.js HTTP/1.1" 200 7199
fe80::1%lo0 - - [24/May/2019:19:02:55 +0200] "GET /lib/jquery/js/jquery.cms_admin.js HTTP/1.1" 200 20065
fe80::1%lo0 - - [24/May/2019:19:02:55 +0200] "GET /lib/jquery/js/jquery.cmsms_dirtyform.js HTTP/1.1" 200 3801
fe80::1%lo0 - - [24/May/2019:19:02:55 +0200] "GET /lib/jquery/js/jquery.cmsms_lock.js HTTP/1.1" 200 8460
fe80::1%lo0 - - [24/May/2019:19:02:55 +0200] "GET /lib/jquery/js/jquery.cmsms_hierselector.js HTTP/1.1" 200 8955
fe80::1%lo0 - - [24/May/2019:19:02:55 +0200] "GET /lib/jquery/js/jquery.cmsms_autorefresh.js HTTP/1.1" 200 2853
fe80::1%lo0 - - [24/May/2019:19:02:55 +0200] "GET /lib/jquery/js/jquery.ui.touch-punch.min.js HTTP/1.1" 200 1291
fe80::1%lo0 - - [24/May/2019:19:02:55 +0200] "GET /lib/jquery/js/jquery.cmsms_filepicker.js HTTP/1.1" 200 5686
fe80::1%lo0 - - [24/May/2019:19:02:55 +0200] "GET /admin/themes/OneEleven/includes/standard.js HTTP/1.1" 200 19099
fe80::1%lo0 - - [24/May/2019:19:02:55 +0200] "GET /admin/themes/OneEleven/css/default-cmsms/jquery-ui-1.10.4.custom.min.css HTTP/1.1" 200 27430
fe80::1%lo0 - - [24/May/2019:19:02:55 +0200] "GET /modules/CGExtensions/css/admin_styles.css HTTP/1.1" 200 2046
fe80::1%lo0 - - [24/May/2019:19:02:55 +0200] "GET /admin/style.php?__c=45c464119d7e6913be1 HTTP/1.1" 200 54007
fe80::1%lo0 - - [24/May/2019:19:02:55 +0200] "GET /admin/cms_js_setup.php?__c=45c464119d7e6913be1 HTTP/1.1" 200 1784
fe80::1%lo0 - - [24/May/2019:19:02:55 +0200] "GET /admin/themes/OneEleven/images/layout/cmsms-logo.jpg HTTP/1.1" 200 9858
fe80::1%lo0 - - [24/May/2019:19:02:55 +0200] "GET /modules/CGBetterForms/images/icon.gif HTTP/1.1" 200 603
fe80::1%lo0 - - [24/May/2019:19:02:55 +0200] "GET /admin/themes/OneEleven/images/icons/system/newobject.gif HTTP/1.1" 200 362
fe80::1%lo0 - - [24/May/2019:19:02:55 +0200] "GET /admin/themes/OneEleven/images/icons/system/import.gif HTTP/1.1" 200 391
fe80::1%lo0 - - [24/May/2019:19:02:55 +0200] "GET /admin/themes/OneEleven/images/icons/system/export.gif HTTP/1.1" 200 381
fe80::1%lo0 - - [24/May/2019:19:02:55 +0200] "GET /admin/themes/OneEleven/images/icons/system/edit.gif HTTP/1.1" 200 372
fe80::1%lo0 - - [24/May/2019:19:02:55 +0200] "GET /admin/themes/OneEleven/images/icons/system/delete.gif HTTP/1.1" 200 385
fe80::1%lo0 - - [24/May/2019:19:02:55 +0200] "GET /admin/themes/OneEleven/images/layout/sprite_repeatx.png HTTP/1.1" 200 797
fe80::1%lo0 - - [24/May/2019:19:02:55 +0200] "GET /admin/themes/OneEleven/images/layout/cms-logo-bg.gif HTTP/1.1" 200 306
fe80::1%lo0 - - [24/May/2019:19:02:55 +0200] "GET /admin/themes/OneEleven/images/layout/welcome-bg.gif HTTP/1.1" 200 158
fe80::1%lo0 - - [24/May/2019:19:02:55 +0200] "GET /admin/themes/OneEleven/images/layout/sprite_norepeat.png HTTP/1.1" 200 18351
fe80::1%lo0 - - [24/May/2019:19:02:55 +0200] "GET /admin/themes/OneEleven/images/layout/sidebar-shadow.png HTTP/1.1" 200 133
fe80::1%lo0 - - [24/May/2019:19:02:55 +0200] "GET /admin/themes/OneEleven/images/layout/navigation-bg.gif HTTP/1.1" 200 150
fe80::1%lo0 - - [24/May/2019:19:02:55 +0200] "GET /admin/themes/OneEleven/images/icons/system/info.gif HTTP/1.1" 200 603


Het maakt overigens niet uit bij welk form ik een scan uitvoer; alle geven dezelfde reactie.


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Hosting Nation - Managed CMSMS Hosting