CMS Made Simple Forums
https://forum.cmsmadesimple.org/

Install script van laatste core-versie 2.2.8, start niet op
https://forum.cmsmadesimple.org/viewtopic.php?f=13&t=79310
Page 1 of 2

Author:  mev [ Mon Oct 29, 2018 12:09 pm ]
Post subject:  Install script van laatste core-versie 2.2.8, start niet op

Bij aanroepen van het install script vd laatste 2.2.8. core-versie, gebeurt er helemaal niks. Het script is ge-upload naar de root (verder leeg).
Deze provider one.com, waar ik de php eerst op versie 7.2 gezet heb, zegt dat het aan de php-versie kan liggen.
In de spec's van cms-ms 2.8.8 staat toch dat ie getest is met php 7.2 en zou moeten draaien!?

Wat kan dit dan zijn, iemand ervaring mee?
Dank alvast.
willemijn

Author:  tristan [ Mon Oct 29, 2018 1:12 pm ]
Post subject:  Re: Install script van laatste core-versie 2.2.8, start niet

Gebruik je de phar versie? Op mijn servers werkt die niet helemaal lekker samen met Opcache, het helpt dan nog wel eens om Opcache, tijdelijk, even uit te zetten of gewoon de "expanded" CMS Made Install up te loaden.

2.2.8 Zou inderdaad prima moeten werken met PHP 7.2, dat doet het hier althans wel.

Author:  mev [ Mon Oct 29, 2018 3:54 pm ]
Post subject:  Re: Install script van laatste core-versie 2.2.8, start niet

Thanks Tristan.
Is de phar gewoon de versie met het bestand cmsms-2.2.8-install.php ?
Ja die gebruikte ik.
Geen idee hoe ik opcache uitzet.. Maar er is hier ook nog geen sprake van niet of wel 'lekker samenwerken', hij start nl niet eens op..

Moet de expanded CMS-MS Install niet via Shell ge-upload? Die toegang hebben ze daar niet.

Mijn vraag is doorgezet naar de IT-afdeling van one.com, benieuwd.

iemand nog 'n tipje?
willemijn

Author:  tristan [ Tue Oct 30, 2018 6:24 am ]
Post subject:  Re: Install script van laatste core-versie 2.2.8, start niet

De expanded kan je ook via ftp uploaden, dat zou heel goed een oplossing kunnen zijn voor je probleem nl.

Anders moet je even proberen uit te vinden hoe je bij de error logs kan komen van je webserver bij one.com om te zien wat er aan de hand is.

Author:  Rolf [ Tue Oct 30, 2018 10:09 am ]
Post subject:  Re: Install script van laatste core-versie 2.2.8, start niet

Heb ik eerder voorbij zien komen. One.com ondersteunt geen PHAR (een standaard PHP functie) wat je nodig hebt om CMSMS te installeren...

Author:  Rolf [ Tue Oct 30, 2018 10:12 am ]
Post subject:  Re: Install script van laatste core-versie 2.2.8, start niet

viewtopic.php?f=13&t=75273

Author:  mev [ Tue Oct 30, 2018 10:19 am ]
Post subject:  Re: Install script van laatste core-versie 2.2.8, start niet

Ja dat zegt one.com nu ook, geen phar ondersteuning. Jeeeee, mooi in de aap gelogeerd!

Uhhm maar er draaide dus tot zondag jl. wél een hele oude cms-ms versie van vele jaren terug. Destijds zelf geinstalleerd...
Is phar alleen nodig om em te installeren? Offe?
Want dan kan ik em installeren mbv de expanded-versie en ftp?

willemijn

Author:  tristan [ Tue Oct 30, 2018 10:20 am ]
Post subject:  Re: Install script van laatste core-versie 2.2.8, start niet

Nee expanded met ftp moet gewoon werken, voor het dagelijks gebruik van CMS Made Simple heb je geen phar nodig.

Author:  mev [ Tue Oct 30, 2018 10:24 am ]
Post subject:  Re: Install script van laatste core-versie 2.2.8, start niet

Maar via die link van Rolf
(viewtopic.php?f=13&t=75273) zegt iemand dat zonder Phar versie 2.2.x niet kan draaien. Hoe zit dat nu?

Author:  tristan [ Tue Oct 30, 2018 10:31 am ]
Post subject:  Re: Install script van laatste core-versie 2.2.8, start niet

Ik denk dat dat een beetje te kort door de bocht is, voor zover ik weet is Phar alleen een requirement voor phar installation assistant maar het staat daar ook niet helemaal duidelijk nu ik het zelf zo doorlees.

Ga het hier meteen even zonder Phar enabled proberen met de expanded install. Alternatief is natuurlijk altijd om naar een fatsoenlijke hoster over te stappen.

Author:  mev [ Tue Oct 30, 2018 10:52 am ]
Post subject:  Re: Install script van laatste core-versie 2.2.8, start niet

Ik zie nu in het readme-bestand van de expanded-installer staan, na unzippen:

Your PHP environment must include the PHAR extension (yes, even for the expanded installer). This is for expanding the archive(s) included within the installation assistant....

Lijkt me dus niet kunnen zonder phar, toch?!

Author:  Rolf [ Tue Oct 30, 2018 12:20 pm ]
Post subject:  Re: Install script van laatste core-versie 2.2.8, start niet

Als de one.com niet van standpunt is verandert dan is het wel een probleem...
Of installeren op eigen server en dan verplaatsen naar... Maar bij upgraden loop je tegen hetzelfde probleem aan.

Author:  mev [ Tue Oct 30, 2018 2:54 pm ]
Post subject:  Re: Install script van laatste core-versie 2.2.8, start niet

Nee denk niet dat one.com dat anders gaan doen. 'k Had gereageerd met dat Phar toch een tamelijk standaard php-functie is. Dit antwoordden ze:
"Nee dit is geen standaard php functie. Voor Phar moeten er bestanden gezet worden op onze interne server, iets wat wij niet toestaan."

Jep zekers een probleem. Kennelijk werd phar voor cmsms noodzakelijk vanaf 2.2.x? Dus bij upgraden in de toekomst idd iedere keer weer idem probleem. Dat wil je toch niet.

Zal klant maar alternatieve provider voorstellen, áls ze cmsms willen behouden. Ze deden er al bijna niks mee... :(

Author:  Rolf [ Tue Oct 30, 2018 3:20 pm ]
Post subject:  Re: Install script van laatste core-versie 2.2.8, start niet

\$1:
Nee dit is geen standaard php functie. Voor Phar moeten er bestanden gezet worden op onze interne server, iets wat wij niet toestaan.

Tja: https://secure.php.net/manual/en/intro.phar.php

Het enige bestand wat tijdelijk op de server gezet moet worden is het installatiebestand, die je na de bewerking moet verwijderen...
One.com is de eerste NL host die ik tot nu toe heb gezien die PHAR niet ondersteund.

Author:  tristan [ Tue Oct 30, 2018 3:48 pm ]
Post subject:  Re: Install script van laatste core-versie 2.2.8, start niet

mev \mev:
Ik zie nu in het readme-bestand van de expanded-installer staan, na unzippen:

Your PHP environment must include the PHAR extension (yes, even for the expanded installer). This is for expanding the archive(s) included within the installation assistant....

Lijkt me dus niet kunnen zonder phar, toch?!


Maar ook geprobeerd wat hij doet als je daarna na de dir gaat waar je hem hebt uitgepakt?

Page 1 of 2 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/