• twitter image
  • facebook image
  • youtube image
  • linkedin image
Language: CMS Made Simple Czech CMS Made Simple France CMS Made Simple Hungary CMS Made Simple Russia CMS Made Simple Netherlands

All times are UTC




Post new topic Reply to topic  [ 17 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: Na SSL-verbind. probl met Gallery-Lightbox én wysywyg-editor
PostPosted: Mon May 07, 2018 11:26 am 
Offline
Power Poster
Power Poster

Joined: Wed Apr 25, 2007 5:00 pm
Posts: 323
Na het instellen van SSL-verbinding is er in een vd cms-ms sites (bij DeHeeg gehost) 2 problemen ontstaan:
1. in alle pag.'s die een Lightbox-gallery hebben, worden de thumbs van Gallery niet meer naast, maar onder elkaar weergegeven (en de vergrotingen niet goed weergegeven).
Heb alles geprobeerd, ook met zoekfunctie in de back-end gezocht naar waar nog http etc gebruikt werd, en die aangepast, etc. etc. Maar mag niet baten. Uiteindelijk het script in de htaccess voor het doorsluizen eruit en handmatig per pagina de optie 'gebruik https voor deze pagina" aangezet voor de pagina's zonder Gallery (die het wel goed doen na de omzetting), behalve die met een gallery.

2. de probleem is dat de editor van de standaard micro-tiny module niet meer in wysywyg-modus wordt getoond. Klant ziet dus alle code en kan er geen wijs uit. Aan de code v content-block toegevoegd dat ie wysywyg moet tonen, helpt niks.
Hoe dit nou toch kan...

Heeft iemand idee in welke richtingen ik het moet zoeken?

Het instellen van SSL/https-verbinding bij paar andere cms-ms-sites (bij andere providers), ging prima, ook die met Gallery.
Moet erbij zeggen dat het cms bij deze site in een submap staat, met doorsluis naar root. Maar ook dat het een behoorlijk oude site is, meer dan 10 jr geleden begonnen met de vroegste versie van cmsms & Gallery (wel steeds ge-upgrade uiteraard).

Het gaat om: http://www.andreschoots.com (en alle subpag.'s van Gallery).

Bij voorbaat hartelijk dank voor het meedenken!
willemijn


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Na SSL-verbind. probl met Gallery-Lightbox én wysywyg-ed
PostPosted: Mon May 07, 2018 11:47 am 
Offline
Dev Team Member
Dev Team Member

Joined: Mon Nov 28, 2011 9:29 am
Posts: 3076
Location: The Netherlands
1.

Quote:
<!-- Gallery/Lightbox-standaard-gallerie -->
<link rel="stylesheet" href="http://www.andreschoots.com/modules/Gallery/templates/css/Lightbox_standaard_gallerie.css" type="text/css" media="screen" />


Dat lijkt me de boosdoener (weet ik zeker). Ik weet zo niet of je dat in de gallery module kunt aanpassen bij het Lightbox template.


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Na SSL-verbind. probl met Gallery-Lightbox én wysywyg-ed
PostPosted: Mon May 07, 2018 2:35 pm 
Offline
Power Poster
Power Poster

Joined: Wed Apr 25, 2007 5:00 pm
Posts: 323
Bedankt Velden,
Nee in de Gallery Sjabloon editor, staat wel de inhoud vh Sjabloon CSS-stylesheet, maar ik zie nergens waar/hoe ie gekoppeld wordt, laat staan op welke plek dat te wijzigen is..

OH jee help, wat nu??

En waarom micro-tiny ineens geen wysiwyg meer heeft?? Heb jij daar missch 'n idee van??

willemijn


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Na SSL-verbind. probl met Gallery-Lightbox én wysywyg-ed
PostPosted: Mon May 07, 2018 2:39 pm 
Offline
Dev Team Member
Dev Team Member

Joined: Mon Nov 28, 2011 9:29 am
Posts: 3076
Location: The Netherlands
Je kunt wellicht controleren of de root_url gezet wordt in de config.php file. Dat zou kunnen helpen.

Het clearen van de cache heb je al gedaan?


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Na SSL-verbind. probl met Gallery-Lightbox én wysywyg-ed
PostPosted: Mon May 07, 2018 2:45 pm 
Offline
Power Poster
Power Poster

Joined: Wed Apr 25, 2007 5:00 pm
Posts: 323
Zie in de paginabron dat de andere stylesheets ook aangeroepen worden met http, dus zonder de s.
Maar die andere styles worden toch wel getoond... rara.
missch omdat die uit de cache gehaald kunnen worden ofzoiets?


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Na SSL-verbind. probl met Gallery-Lightbox én wysywyg-ed
PostPosted: Mon May 07, 2018 4:05 pm 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Wed Apr 23, 2008 7:53 am
Posts: 7642
Location: The Netherlands
Allemaal hier beschreven:
https://www.cmscanbesimple.org/blog/set ... ade-simple

_________________
Image

Did my post help you solving a problem at your (customers) website and it saved you many hours of work? Great!! Consider buying me a cup of coffee in return!



Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Na SSL-verbind. probl met Gallery-Lightbox én wysywyg-ed
PostPosted: Mon May 07, 2018 4:13 pm 
Offline
Power Poster
Power Poster

Joined: Wed Apr 25, 2007 5:00 pm
Posts: 323
Quote:
Je kunt wellicht controleren of de root_url gezet wordt in de config.php file. Dat zou kunnen helpen.

Het clearen van de cache heb je al gedaan?


Jep de root_url (én admin-url) staan uiteraard goed in de config.php, 1 vd eerste maatregelen.
Clear cache al tig keer gedaan.

Ik heb nu de gehele css-code van het gallery-lightbox-standaard sjabloon gekopieerd in een nieuw stylesheet en die ook aan de pagina-sjablonen vd gallery-pagina's gehangen. Getest voor 1 pagina, die het nu gelukkig ook via een https-verbinding wel goed doet.
Niet echt 'n elegante oplossing en vraag me ook af wat er gebeuren gaat na volgende upgrades...

het probleem vd wysiwyg-modus krijg ik niet opgelost helaaaaaas.

Iemand anders een clue??
willemijn


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Na SSL-verbind. probl met Gallery-Lightbox én wysywyg-ed
PostPosted: Mon May 07, 2018 4:21 pm 
Offline
Power Poster
Power Poster

Joined: Wed Apr 25, 2007 5:00 pm
Posts: 323
Quote:


Jep Rolf, had al dankbaar gebruik gemaakt van die post van jouw en vrijwel alles zo gedaan (behalve de aanpassing vd htaccess vooor alle pagina's in ene; dat per pagina nu eve in de opties gedaan, 'Gebruik https voor deze pagina', omdat anders alle gellery-pagina's de thumbs zo raar weergaven).

Heb jij missch. nog 'n tipje wat te doen bij de mircro-tiny editor die geen wysiwyg modus wil tonen????

willemijn


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Na SSL-verbind. probl met Gallery-Lightbox én wysywyg-ed
PostPosted: Mon May 07, 2018 6:40 pm 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Wed Apr 23, 2008 7:53 am
Posts: 7642
Location: The Netherlands
Weet je zeker dat het gewijzigde config.php bestand daadwerkelijk op de server aanwezig is en niet lokaal is blijven hangen? Je zult niet de eerste zijn...

Op de gallery pagina's kom ik nml. <base href="http://www.andreschoots.com/" /> tegen (zonder https) en dat zou niet moeten kunnen als de root_url in de config is opgenomen.

grt. Rolf

Ps. Er vanuitgaande dat je de {metadata} tag in je pagina sjabloon gebruikt...

_________________
Image

Did my post help you solving a problem at your (customers) website and it saved you many hours of work? Great!! Consider buying me a cup of coffee in return!



Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Na SSL-verbind. probl met Gallery-Lightbox én wysywyg-ed
PostPosted: Mon May 07, 2018 8:52 pm 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Wed Apr 23, 2008 7:53 am
Posts: 7642
Location: The Netherlands
Ohw en in de Admin als iets niet blijkt te werken kan het ook browser caching zijn. CTRL F5 of CMD R doet dan soms wonderen!

_________________
Image

Did my post help you solving a problem at your (customers) website and it saved you many hours of work? Great!! Consider buying me a cup of coffee in return!



Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Na SSL-verbind. probl met Gallery-Lightbox én wysywyg-ed
PostPosted: Mon May 07, 2018 11:43 pm 
Offline
Power Poster
Power Poster

Joined: Wed Apr 25, 2007 5:00 pm
Posts: 323
Quote:
Weet je zeker dat het gewijzigde config.php bestand daadwerkelijk op de server aanwezig is en niet lokaal is blijven hangen? Je zult niet de eerste zijn...


Als ik de config.php met FTP (filezilla) bekijk aan de serverskant, staat daar toch echt in:
$config['root_url'] = 'https://www.andreschoots.com';
$config['admin_url'] = 'https://www.andreschoots.com/admin';

Heul bijzonder dat er dan toch als base href="http://www.andreschoots.com/" /> in de paginabron staat...
Hoe ken dat?
(de pagina-optie "gebruik voor deze pag. https" is daar voor nu nog wel uit gevinkt, doet die dat missch ook??).

Quote:
Ohw en in de Admin als iets niet blijkt te werken kan het ook browser caching zijn. CTRL F5 of CMD R doet dan soms wonderen!


Ctrl-F5 al tig keer gedaan, as usual..
En behalve in Chrome, ook met IE en Firefox gekeken (beide ge-update-te/laatste versies),
maar ook bij die browsers tonen alle pagina's de als content-block gecodeerde editor-vakken geen wysiwyg-modus en wordt dus alle code getoond!
Lijkt dus niet browser-specifiek, noch -caching.

Er is wat anders aan de hand.
Maar wat, in welke richting te zoeken??

Hoe dan ook, heel veel dank voor 't meedenken, super fijn!
willemijn


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Na SSL-verbind. probl met Gallery-Lightbox én wysywyg-ed
PostPosted: Tue May 08, 2018 8:18 am 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Wed Apr 23, 2008 7:53 am
Posts: 7642
Location: The Netherlands
De HTTPS optie bij de pagina's in Content Manager moet/hoef je niet te gebruiken.
Niet aanvinken dus!
In het pagina overzicht kun je alle pagina's selecteren en dan "Set Insecure HTTP), dan cache legen en weer proberen.

De base-href tag wordt gegenereerd door de {metadata} tag en staan niet hardcoded in de sjablonen?

Wellicht met de Admin backend zoekmachine zoeken op http:

_________________
Image

Did my post help you solving a problem at your (customers) website and it saved you many hours of work? Great!! Consider buying me a cup of coffee in return!



Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Na SSL-verbind. probl met Gallery-Lightbox én wysywyg-ed
PostPosted: Tue May 08, 2018 9:36 am 
Offline
Power Poster
Power Poster

Joined: Wed Apr 25, 2007 5:00 pm
Posts: 323
Dat had ik tijdelijk gedaan Rolf, alleen voor de pagina's zonder Gallery en om die wel van https gebruik te laten maken. Dit omdat, als ik omgekeerd mbv de htaccess alles wel over https laat lopen, de Galleries dus niet goed toonden (thumbs en vergrotingen). En dat kan niet, die klant heeft nu namelijk een expo...dan wil je alle schilderijen laten zien, ook vergrotingen.
Hoe "erg" is het trouwens om die pagina-optie voor https te gebruiken (per pagina)??

Quote:
De base-href tag wordt gegenereerd door de {metadata} tag en staan niet hardcoded in de sjablonen?

In de 3 pagina-sjablonen staat overal alleen {metadata}, niet hardcoded.
Offe, bedoel je wat anders?

Quote:
Wellicht met de Admin backend zoekmachine zoeken op http:
. Dat had ik al aantal keren gedaan -en aanpassingen gedaan-, zie m'n 1e post.

willemijn


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Na SSL-verbind. probl met Gallery-Lightbox én wysywyg-ed
PostPosted: Tue May 08, 2018 9:55 am 
Offline
Power Poster
Power Poster

Joined: Wed Apr 25, 2007 5:00 pm
Posts: 323
Het issue van de mircro-tiny editor die geen wysiwyg modus wil tonen, heeft hopelijk niet te maken met die https-knop in de pagina-opties, I guess?


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Na SSL-verbind. probl met Gallery-Lightbox én wysywyg-ed
PostPosted: Tue May 08, 2018 1:02 pm 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Wed Apr 23, 2008 7:53 am
Posts: 7642
Location: The Netherlands
Dan zou ik het niet weten... In een normale situatie zou dit moeten werken...

_________________
Image

Did my post help you solving a problem at your (customers) website and it saved you many hours of work? Great!! Consider buying me a cup of coffee in return!



Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 17 posts ]  Go to page 1, 2  Next

All times are UTC


Who is online

Users browsing this forum: No registered users


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Hosting Nation - Managed CMSMS Hosting