CMS Made Simple Forums
https://forum.cmsmadesimple.org/

Redirect 301 werkt alleen met een ? Hoe haal ik die weg?
https://forum.cmsmadesimple.org/viewtopic.php?f=13&t=77772
Page 1 of 1

Author:  (M) [ Thu Dec 28, 2017 11:35 pm ]
Post subject:  Redirect 301 werkt alleen met een ? Hoe haal ik die weg?

In mijn .htaccess heb ik het volgende staan:
\$1:
Redirect 301 /oudesite/features-old.html http://upgrade.oudesite.com/features.html?

Zonder het ? (aan het einde van de Redirect 301) krijg ik een url die niet werkt; http://upgrade.oudesite.com/features.html?page=features-old.html

Met het ? op het einde krijg ik een url die wel werkt; http://upgrade.oudesite.com/features.html?
Maar hoe krijg ik het ? weg in dit resultaat?

Author:  Rolf [ Fri Dec 29, 2017 12:27 am ]
Post subject:  Re: Redirect 301 werkt alleen met een ? Hoe haal ik die weg?

Dit al geprobeerd https://www.cmscanbesimple.org/blog/red ... ade-simple ?

Author:  (M) [ Fri Dec 29, 2017 11:16 am ]
Post subject:  Re: Redirect 301 werkt alleen met een ? Hoe haal ik die weg?

Het gaat om External Redirects.
De oplossing die daarbij op je website staat werkt niet. Ik heb ook varianten geprobeerd, zonder resultaat.

Met een ‘RewriteRule’ werkt de redirect niet. Het werkt alleen met ‘Redirect 301’.
Met het ? op het einde krijg ik tenminste geen ‘?page=features-old.html’
als resultaat. Maar wel een url die eindigt op .html?

Author:  velden [ Tue Feb 13, 2018 1:04 pm ]
Post subject:  Re: Redirect 301 werkt alleen met een ? Hoe haal ik die weg?

Wellicht kun je de hele inhoud van de .htaccess eens posten. Vermoedelijk zit het probleem in een andere rule/redirect

Page 1 of 1 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/