• twitter image
  • facebook image
  • youtube image
  • linkedin image
Language: CMS Made Simple Czech CMS Made Simple France CMS Made Simple Spain CMS Made Simple Hungary CMS Made Simple Russia CMS Made Simple Netherlands

All times are UTC




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: Zmiana serwera, polskie znaki i garść problemów nowicjusza
PostPosted: Thu Jun 03, 2010 8:24 am 
Offline
New Member
New Member

Joined: Thu Jun 03, 2010 8:04 am
Posts: 2
Witajcie,
Po raz pierwszy na forum i oczywiście z problemem.
Jak zaznaczyłem w tytule, rzecz dotyczy przenosin. Mnóstwo już na ten temat zostało napisane, dużo też się naczytałem, ale tego co się u mnie dzieje wyjaśnić i naprawić sam nie umiem.

Pierwotnie strona znajdowała się tu - i nadal tu jest, ale już nie długo.
http://www.tanglangsuwalki.vizjer.com
Polskie znaki jak widać śmigają.
Stronę następnie przeniosłem tu:
vizjer.vot.pl/tanglangsuwalki
...i już widać, że jest coś nie tak.

Opiszę co robiłem.
1. Przenosimy CMS przez ftp. Kopia na dysk, potem wysyłka do katalogu docelowego - proste.
2. Przenosiny bazy - trudne.
- Macierzyste kodowanie: latin1_swedish_ci. Export z PHP MyAdmin do pliku.
- Następnie, jak wskazywano w wielu miejscach, ręczna konwersja liter w Notepad++ na polskie znaki, kodowane w UTF8 - pracochłonne, ale proste.
- Następnie import bazy w nowym miejscu (ustawiony format latin1 - narazie).
- Konwersja kodowania baz poleceniem ALTER TABLE cms_additional_htmlblob_users CONVERT TO CHARACTER SET utf8 COLLATE utf8_unicode_ci; - prawie wszystkich, bo baza cms_module_templates musi zostać w latin1_swedish_ci - inaczej MySQL wywala błąd.

W tym momencie, teoretycznie, strona jest zakodowana w UTF8. Treść i bazy są w UTF8, config.php, też ustawiony na UTF8, a strona robi co chce.
Proszę bardzo:
Strona główna jak widać krzaczy. Dalej...
http://www.vizjer.vot.pl/tanglangsuwalki/index.php?page=modliszka_historia - tu jest OK, ale tylko na stronie, w edytorze już krzaki.
http://www.vizjer.vot.pl/tanglangsuwalki/index.php?page=modliszka_mistrzowie - tu w ogóle kuriozum, bo znaki zaczynają wyświetlać się prawidłowo po przestawieniu kodowania w przeglądarce na ISO8859-2. W edytorze tak samo.

Koleżanki i koledzy, podpowiedzcie co mam zrobić, żeby cała ta strona poszła jednolicie w UTF8, bo już kłaki rwę z głowy. Wszystkie fora przewaliłem, google już mi nie pomagają... Czegoś nie wiem i czegoś nie umiem, ale czego... i jak to zrobić? Pomocy!

========edit
To co tu dopiszę, albo naprowadzi na rozwiązanie, albo bardziej sprawę skomplikuje - dla mnie komplikuje.
Treść prawidłowo wyświetlana na stronie (UTF-8), po wejściu do edycji 'krzaczy'. Dopiero po przestawieniu kodowania w przeglądarce na 8859-2 wyświetla się prawidłowo (ciągle mowa o edycji).
Nadmienię, że plik config.php zawiera odpowiednie wpisy zarówno dla strony, jak też menu admina - UTF-8.  ???


Last edited by majoris on Thu Jun 03, 2010 10:41 am, edited 1 time in total.

Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Zmiana serwera, polskie znaki i garść problemów nowicjusza
PostPosted: Fri Jun 04, 2010 8:16 am 
Offline
Forum Members
Forum Members
User avatar

Joined: Thu Jan 29, 2009 1:37 pm
Posts: 113
Czesc,
nie pamietam dokladnie jak to u mnie było, ale chyba zmieniałem kodowanie dla poszczegolnych pol w tabelach w phpMyAdmin - już po przenosinach bazy i po konwersji dumpa na UTF-8.
Mialem te same objawy.
Jak sobie przypomne to dam znać.

Pozdrawiam
Olek

_________________
---------------
olek@miniperfumeria.com


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Zmiana serwera, polskie znaki i garść problemów nowicjusza
PostPosted: Fri Jun 04, 2010 12:18 pm 
Offline
Forum Members
Forum Members

Joined: Tue May 04, 2010 5:04 pm
Posts: 249



Zmień język na PL. W kodzie strony maż deklarację na EN. Może to pomoże?
Ewentualnie sprawdź w MyAdmin czy kodowanie metody porównywania napisów to napewno: utf8_general_ci

Pozdrawiam,
Marek A.


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Zmiana serwera, polskie znaki i garść problemów nowicjusza
PostPosted: Fri Jun 04, 2010 2:52 pm 
Offline
New Member
New Member

Joined: Thu Jun 03, 2010 8:04 am
Posts: 2
Maranc, trochę mnie naprowadziłeś..
Pozaglądałem sobie w źródła stron i wyszło, że mam ustawione w globalnych metadanych  iso-8859-2. Na macierzystej stronie miałem utf-8 i wsio grało. Musiałem to przeoczyć. Będę rzeźbił w tym kierunku, zobaczę co z tego będzie. Jak już to poskromię, dam znać.
========edit
Okazuje się, że powyższe nie pomaga. Nie ma to żadnego związku z wyświetlaniem. Nawet biorąc na logikę. Globalne metadane były ustawione na iso-8859-2, a różne podstrony wyświetlały się z różnym skutkiem. Więc to nie to. Szukam dalej.

Nadal oczekuję na sugestie. Postaram się sprawdzić wszystkie, których do tej pory nie testowałem.


Last edited by majoris on Fri Jun 04, 2010 5:58 pm, edited 1 time in total.

Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
A2 Hosting