Link zu PDF-Datei ergibt "You don't have permission to access this resource."

Deutschsprachiger Support für CMS Made Simple
Post Reply
User avatar
caigner
Forum Members
Forum Members
Posts: 34
Joined: Sun Aug 16, 2020 5:29 am

Link zu PDF-Datei ergibt "You don't have permission to access this resource."

Post by caigner »

Hallo!

Eigentlich hab ich etwas sehr triviales gemacht: Ich habe mit dem File Manager eine PDF-Datei in den /uploads/doc-Ordner hochgeladen.
Danach habe ich im Content meiner Seite mit dem WYSIWYG-Editor einen Link zu diesem Dokument eingefügt.

Der Link sieht so aus:
Soweit alles ok. Nur wenn ich auf der Webseite dann den Link anklicke, erhalte ich folgende Meldung:
403 Forbidden
You don't have permission to access this resource.
Ich nehme mal an, ich muß in einer der .htaccess-Dateien etwas ändern, aber was?

Vielen Dank schon mal im Voraus für die Hilfe!

Christian
I am using CMSms 2.2.16
1541
Forum Members
Forum Members
Posts: 32
Joined: Fri Nov 10, 2017 10:25 am
Location: .de

Re: Link zu PDF-Datei ergibt "You don't have permission to access this resource."

Post by 1541 »

Hallo Christian,

ich denke, das hat weniger mit CMSMS zu tun als mit der Berechtigung (chmod) und dem Besitzer deines Verzeichnisses "/uploads/doc/".
Wie sieht denn das chmod vom Verzeichnis "doc" aus? "755"?
Wer ist der Besitzer des Verzeichnisses?
Welche Berechtigung hat die PDF-Datei selbst? "644"?

VG
1541
User avatar
caigner
Forum Members
Forum Members
Posts: 34
Joined: Sun Aug 16, 2020 5:29 am

Re: Link zu PDF-Datei ergibt "You don't have permission to access this resource."

Post by caigner »

Das Verzeichnis "doc" hat 775 und die PDF-Datei hat 644.
Es sollten also alle Website-Besucher lesenden Zugriff darauf haben.

Besitzer des Verzeichnisses ist der selbe, dem auch das uploads-Verzeichnis gehört. Ich habe das Verzeichnis in der Admin-Umgebung mittels File-Manager angelegt. Sollte also alles passen. Deshalb bin ich auch so überrascht, daß es nicht geht.
I am using CMSms 2.2.16
User avatar
DIGI3
Dev Team Member
Dev Team Member
Posts: 1472
Joined: Wed Feb 25, 2009 4:25 am
Location: Victoria, BC

Re: Link zu PDF-Datei ergibt "You don't have permission to access this resource."

Post by DIGI3 »

(Sorry for the English) - check your .htaccess file, the one that ships with CMSMS has this line:

Code: Select all

RedirectMatch 403 ^.*/doc/.*$
You'll need to change it to be more specific to the site root /doc/ folder.
Not getting the answer you need? CMSMS support options
User avatar
caigner
Forum Members
Forum Members
Posts: 34
Joined: Sun Aug 16, 2020 5:29 am

Re: Link zu PDF-Datei ergibt "You don't have permission to access this resource."

Post by caigner »

So, what should

Code: Select all

RedirectMatch 403 ^.*/doc/.*$
look like, so that a PDF can be downloaded? Should I remove it from the .htaccess file?
I am using CMSms 2.2.16
User avatar
DIGI3
Dev Team Member
Dev Team Member
Posts: 1472
Joined: Wed Feb 25, 2009 4:25 am
Location: Victoria, BC

Re: Link zu PDF-Datei ergibt "You don't have permission to access this resource."

Post by DIGI3 »

Comment it out to confirm it fixes the issue, then I think you could change it to

Code: Select all

RedirectMatch 403 ^/doc/.*$
to block just the root /doc/ folder and its contents, but not any folder with the name 'doc'.
Not getting the answer you need? CMSMS support options
User avatar
caigner
Forum Members
Forum Members
Posts: 34
Joined: Sun Aug 16, 2020 5:29 am

Re: Link zu PDF-Datei ergibt "You don't have permission to access this resource."

Post by caigner »

Commenting out worked! Thanks for your help!
I am using CMSms 2.2.16
1541
Forum Members
Forum Members
Posts: 32
Joined: Fri Nov 10, 2017 10:25 am
Location: .de

Re: Link zu PDF-Datei ergibt "You don't have permission to access this resource."

Post by 1541 »

I'd recommend you keep the original htaccess rule, because now everybody can download the file

Code: Select all

rootdir/doc/CHANGELOG.txt
and can determine your current CMSMS version which could be a security concern.
Maybe you should rename your document directory from

Code: Select all

rootdir/uploads/doc/
to

Code: Select all

rootdir/uploads/dokumente/
This way the current htaccess rule

Code: Select all

^.*/doc/.*$
won't match anymore and the downloads will work.
Post Reply

Return to “German - Deutsch”