CMS Made Simple Forums
https://forum.cmsmadesimple.org/

0.13 Beta4 Released!
https://forum.cmsmadesimple.org/viewtopic.php?f=1&t=4514
Page 3 of 3

Author:  Dr.CSS [ Sun May 14, 2006 11:24 am ]
Post subject:  Re: 0.13 Beta4 Released!

here you go 2 flavors the whole anchilada or just the update files all zipped up and ready to go out and play...;)...

http://www.multiintech.com/index.php

  mark

Author:  Russ [ Sun May 14, 2006 12:13 pm ]
Post subject:  Re: 0.13 Beta4 Released!

Many thanks Mark, when I can shake of that 'Sunday Feeling' I'll get testing :)

Seeing what you've been playing with, maybe it would be good to create a proper blog module based on news. With perhaps 'captacha' for blog entry to stop spam etc. That way we can tailor a new set of fields for a blog and a more blog like data entry form. What do you think? I can have a look and put together something. It could then have nice url's like the news module:

http://www.domain/news/2005-05-30/newsstory ...

http://www.domain/blog/2005-06-31/blogentry ...

We could also add a calendar type display for retrieving older news items and also a mini side bar display of the top five or so items like you have already done.

Russ

Author:  Dr.CSS [ Sun May 14, 2006 9:04 pm ]
Post subject:  Re: 0.13 Beta4 Released!

actually i've rewriten a news module to include the word blog to make it diff. than the news that's where the 'Comments' link comes from it used to be the [More] link for news and thru in a comments counter tag that Elijah(?sp) worked up. i needed Blog for client.
you did look around and found this  http://www.multiintech.com/index.php?page=blogger  she likes purple....

  mark

Author:  Redguy [ Sun May 14, 2006 10:09 pm ]
Post subject:  Re: 0.13 Beta4 Released!

how can I get rid of index.php in http://localhost/cmsms/index.php/submenu/something/ ?? and why isn't that the default?

and by the way, good stuff ;)

Author:  Ron@Spikecity [ Sun May 14, 2006 10:13 pm ]
Post subject:  Re: 0.13 Beta4 Released!

I have one possible problem with the clean urls in 0.13b4.

All works OK (even without mod_rewrite and Apache but using a similar mechanism built into Sambar 6.4 all-in-one server, until you enter the admin center and try to edit a page.
Everything looks if it is loading OK, but instead of the content in the editor window I get a Page Not Found.

I've tried about every possible combination, with or without extention, with mod rewrite assumed true and false but the only option where it works both on the frontdoor and in the admin center is without the clean url option.

Author:  Dr.CSS [ Sun May 14, 2006 10:23 pm ]
Post subject:  Re: 0.13 Beta4 Released!

redguy
i'm not sure how to do that...
i can't figure out why i get this.. http://www.multiintech.com/index.php?page=Round
instead of this... http://mit-computers.com/index.php/home  or this... http://mit-computers.com/index.php/navi ... us/navleft

both running... CMS Made Simple 0.13-beta4 "Canary"

mit-computers  fresh install other one is upgrade... would like to at least get rid of index.php?page=

    mark

Author:  Elijah Lofgren [ Mon May 15, 2006 3:19 am ]
Post subject:  Re: 0.13 Beta4 Released!

Redguy \Redguy:
how can I get rid of index.php in http://localhost/cmsms/index.php/submenu/something/ ?? and why isn't that the default?

See: http://wiki.cmsmadesimple.org/index.php ... And_Tricks for how to do it. It's not default because not every server has mod_rewrite installed or enabled.

mark \mark:

You need to change this option in config.php to use index.php/Round instead of  index.php?page=Round.
\$1:
#If you don't use mod_rewrite, then would you like to use the built-in
#pretty url mechanism?  This will not work with IIS and the {metadata} tag
#should be in all of your templates before enabling.
$config['internal_pretty_urls'] = true;


And if you want to not have index.php in the URL at all see: http://wiki.cmsmadesimple.org/index.php ... And_Tricks

Author:  Redguy [ Mon May 15, 2006 11:57 am ]
Post subject:  Re: 0.13 Beta4 Released!

Elijah Lofgren \Elijah Lofgren:
Redguy \Redguy:
how can I get rid of index.php in http://localhost/cmsms/index.php/submenu/something/ ?? and why isn't that the default?

See: http://wiki.cmsmadesimple.org/index.php ... And_Tricks for how to do it. It's not default because not every server has mod_rewrite installed or enabled.


Ok, thanks man :)

Author:  Dr.CSS [ Mon May 15, 2006 3:02 pm ]
Post subject:  Re: 0.13 Beta4 Released!

Russ
i'm using the 'Comments' Module which has captcha already, i just haven't called it,and it has 'emailfield' and 'websitefield' if you leave an email add. when you leave a comment it makes your name the email link that is encrypt. so it can't be harvested for spam. a very nice module i must say.

    mark

Author:  Russ [ Mon May 15, 2006 5:03 pm ]
Post subject:  Re: 0.13 Beta4 Released!

Thanks for the info Mark, I still havn't had chance to play with this (and I want to!) but I'm stuck with a steep learning curve for Qcodo (PHP MVC,) because a client wants some stuff yesterday - me - I can just about get the examples working - sigh... and all I want to do is play with this...

Russ

Author:  gogou [ Fri May 19, 2006 1:14 am ]
Post subject:  Re: 0.13 Beta4 Released!

Don't know why but using default css menu horiz 1c I got this error:

Not Found

The requested URL /cmsms/index.php/home was not found on this server.
Apache/2.0.46 (Red Hat) Server at www.ltas.ulg.ac.be Port 80

assuming home is my first page, this is working when making a simple link http://www.ltas.ulg.ac.be/cmsms/index.php?page=home
Why using the menu it is not working? Didn't have that problem on 0.12.2 (ps I cannot modify the config file of the server, it is a school server)

Except that, it is a fine release.

Author:  Ted [ Fri May 19, 2006 1:33 am ]
Post subject:  Re: 0.13 Beta4 Released!

If you set the internal_pretty_urls option in config.php (in the CMSMS document root) to false, it should fix the url problem for you.

Author:  gogou [ Fri May 19, 2006 3:37 am ]
Post subject:  Re: 0.13 Beta4 Released!

Perfect, thanks a lot :)

Author:  petert [ Fri May 19, 2006 6:26 am ]
Post subject:  Re: 0.13 Beta4 Released!

news doesn't seem to work with 'use_hierarchy' turned on?

Page 3 of 3 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/