CMS Made Simple Forums
https://forum.cmsmadesimple.org/

Announcing CMS Made Simple 1.7 - Cape Verde
https://forum.cmsmadesimple.org/viewtopic.php?f=1&t=42573
Page 1 of 1

Author:  calguy1000 [ Sat Mar 20, 2010 8:19 pm ]
Post subject:  Announcing CMS Made Simple 1.7 - Cape Verde

This version marks a milestone for CMSMS, and although the changes in the code are minor, the ramifications are significant, so please read this article in it's entirety.

As of this release we no longer support PHP 4.x - This means that you cannot upgrade your site to CMSMS 1.7 if your host is still running PHP 4.x.  We encourage you to upgrade to PHP 5.2 or PHP 5.3 as soon as possible.   This allows us to move forward with PHP and also as developers to take advantage of many of the new features in this programming language.   If you could see me right now, you'd see me doing the dance of joy... PHP 4.x and PHP 5.x compatibility have been a thorn in our side for a long time.

Also, we now require PHP 5.2.4 as a minimum and recommend PHP 5.2.12 or PHP 5.3.1 and higher.  Why these specific versions you ask?  Well it's a matter of experience.   We have learned through much difficulty, and many days of debugging that some of the earlier versions of PHP 5.2.x were buggy, but have had reasonable success with version 5.2.4 and onwards.  Additionally some users using some of the newer released modules that take serious advantage of some of the advanced features of PHP 5.x (like my modules) will experience some (often strange) difficulties unless you are running a later version of PHP 5.2 or PHP 5.3.

In order to support PHP 5.3 in CMSMS and to release it as soon as possible, we did the minimal amount of changes required to get our functionality to be stable.   This has some ramifications, particularly for those running the latest and greatest software in a development/testing environment.  Specifically we require that E_STRICT and E_DEPRECATED be turned off from your error reporting.

E_STRICT:
As we stated above we did the minimal amount of changes required to get the functionality stable in PHP 5.3.  Some of the core functionality still assumes PHP 4 and does some strange things that are against the model of PHP 5.3's syntax.  As well, some of the libraries that CMSMS uses for things like ajax do not support E_STRICT.  We are also sure many of the add-on modules do too.  Therefore E_STRICT must be disabled.

Note: E_STRICT is not included in E_ALL, however it may have been turned on by your provider and may need to be overridden.

E_DEPRECATED:
Some modules (even some parts of the core) use functions that are valid in PHP 4, and in PHP 5.2.x, but are not valid in PHP 5.3.  And to ensure that all of the functionality works as intended you will need to disable warnings about usage of these functions.  Therefore E_DEPRECATED must also be disabled.  This only applies to PHP 5.3.x

php.ini settings for PHP 5.2.x
The recommended value for error_reporting in your php.ini is:
error_reporting = E_ALL

.htacces settings for PHP 5.2.x
The error reporting value in a .htaccess file has to be specified as an integer.  
php_value error_reporting 6143

error_reporting set directly in PHP
If none of these options work, you may have luck with this line in your config.php:
error_reporting(E_ALL);

php.ini settings for PHP 5.3.x
The recommended value for error_reporting in your php.ini is:
error_reporting = E_ALL &  ~E_DEPRECATED

.htaccess settings for PHP 5.3.x
The error reporting value in a .htaccess file has to be specified as an integer.  
php_value error_reporting 22527

error_reporting set directly in PHP
If none of these options work, you may have luck with this line in your config.php:
error_reporting(E_ALL & ~E_DEPRECATED);

Changes
Along with PHP 5.3 support, a handful of other changes and a sprinkling of minor bug fixes have been thrown into this release.  The description of them follows:

Version 1.7 - Cape Verde
- We now support php 5.3
  Note: Minimum PHP Version required is 5.2.4 though we recommend PHP 5.2.12
   - Users that are using many of the newer modules that take advantage of PHP 5's OOP features
     may experience strange problems when using earlier versions of PHP 5.2.  It is therefore
     recommended that your PHP version be updated frequently.
 Note: We do NOT support E_DEPRECATED or E_STRICT at this time.
 Note: We no longer support PHP 4.x
- The installer no longer performs smarty caching
- Improvements to TinYMCE
 - Now not depending on admin-theme's icons anymore. Thanks Nuno
 - Updated to Tiny 3.3-final
 - Added an option to generate cms-compatible thumbnails when uploading files though the filepicker.
- Search 1.6.2
 - Adds the detailpage param (can be overridden by modules)
- ModuleManager 1.3.3
 - Minor improvements... mostly for PHP 5.3
- Remove the long-deprecated ImageGallery plugin
- Various small bug fixes

Thanks
We would like to thank all of the dev team members (including JeremyBass our newest member) who spent hours making the appropriate changes and testing them.  

We hope you enjoy this release, and feel free to use PHP 5.3 now....
Let the parties begin.

Author:  Bash Gordon [ Mon Mar 22, 2010 10:29 am ]
Post subject:  Re: Announcing CMS Made Simple 1.7 - Cape Verde

For how long will you provide security patches for 1.6 branch?

I would like to note that I was shocked seeing also support for php 5.1.x dropped. You will find lots of (in particular university) hosts out there still running long term distributions as e.g. SLES 10 (supported until 2013!).

CMS no longer so simple :(
Bash

Author:  cyberman [ Wed Mar 24, 2010 7:23 am ]
Post subject:  Re: Announcing CMS Made Simple 1.7 - Cape Verde

A little notice - some hosters doesn't modify PHP enviroment to local needs. Sometimes the value

\$1:
date.timezone = 'America/Los_Angeles'


in php.ini is missed. But this value is needed by PHP 5.3 - without you will get error message like

\$1:
Warning: strtotime() [function.strtotime]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier.


If you have no access to php.ini, you can add this to your config.php

\$1:
date_default_timezone_set('America/Los_Angeles');


Of course you should use your local timezone ;)

http://www.php.net/manual/en/timezones.php

Author:  replytomk3 [ Wed Mar 24, 2010 2:56 pm ]
Post subject:  Re: Announcing CMS Made Simple 1.7 - Cape Verde

I was surprised to see the 1.7 available for download, but no release notice on the forum until now.

Well, I already have 2 sites upgraded to 1.7. I kicked the tires around a bit and it looks ok.

I thank all developers and people involved for this work.

Page 1 of 1 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/