Security Upgrade: CMSMS 1.6.3

Project Announcements. This is read-only, as in... not for problems/bugs/feature request.
Post Reply
calguy1000
Support Guru
Support Guru
Posts: 8169
Joined: Tue Oct 19, 2004 6:44 pm
Location: Fernie British Columbia, Canada

Security Upgrade: CMSMS 1.6.3

Post by calguy1000 »

Announcing CMSMS 1.6.3 - Touho
----------------------------------------------

IMPORTANT
This release fixes a rather important security issue in the printing module as reported by a very helpful user.  We recommend you upgrade to this version of CMSMS as soon as possible.

Additionally, a couple of minor errors relating to deactivating and re-activating content in the content list... and to using {cms_selflink} to point to inactive pages have been fixed.

Short, sweet, and simple.
Please upgrade ASAP.

Thanks.
Follow me on twitter
Please post system information from "Extensions >> System Information" (there is a bbcode option) on all posts asking for assistance.
--------------------
If you can't bother explaining your problem well, you shouldn't expect much in the way of assistance.
Pierre M.

Re: Security Upgrade: CMSMS 1.6.3

Post by Pierre M. »

Thank you for the fix. Thank you "very helpful user" for the feedback.

Pierre M.
NashBridges
Forum Members
Forum Members
Posts: 75
Joined: Sun Jun 15, 2008 2:29 pm

Re: Security Upgrade: CMSMS 1.6.3

Post by NashBridges »

hi
the second update after 1.6.2 which makes problems…

project 1:
1.6 to 1.6.2: i get an error like: Fatal error: Call to a member function GetURL() on a non-object in /var/www/html/web723/html/eagles/tmp/templates_c/%%6E^6E4^6E4E713C%%tpl_head%3A23.php on line 11 when accessing any childpage… problem still exists (even after update to 1.6.3)

project 2:
1.6.2 to 1.6.3: Fatal error: Cannot redeclare class Printing in /var/www/html/web723/html/neu/modules/Printing/Printing.module.php on line 498

anyway, you should test your updates in a better way…
do you know a solution for me?
calguy1000
Support Guru
Support Guru
Posts: 8169
Joined: Tue Oct 19, 2004 6:44 pm
Location: Fernie British Columbia, Canada

Re: Security Upgrade: CMSMS 1.6.3

Post by calguy1000 »

anyway, you should test your updates in a better way…


anyway you should have joined the beta test group when we were asking for people... quality of code in a release is directly proportional to the amount of time contributed to testing... and 3 people can't do it all.
and anyway you should follow the rules and follow post enough information for us to be able to help you with.
Follow me on twitter
Please post system information from "Extensions >> System Information" (there is a bbcode option) on all posts asking for assistance.
--------------------
If you can't bother explaining your problem well, you shouldn't expect much in the way of assistance.
NashBridges
Forum Members
Forum Members
Posts: 75
Joined: Sun Jun 15, 2008 2:29 pm

Re: Security Upgrade: CMSMS 1.6.3

Post by NashBridges »

*gg*
anyway... ok...
sorry didn't want to criticise you that way... never mind... in fact i have problems with the last two releases of cms ms...

1) an exact definition for my problem you can find here: http://forum.cmsmadesimple.org/index.ph ... #msg171405

2) what additional information do you need? i just made an update from 1.6.2 to 1.6.3 today and suddenly get this printer.module error... 1.6.2 worked fine...
alby

Re: Security Upgrade: CMSMS 1.6.3

Post by alby »

NashBridges wrote:sorry didn't want to criticise you that way... never mind... in fact i have problems with the last two releases of cms ms...


Update to latest release and follow Upgrading steps in Documentation

Alby
Post Reply

Return to “Announcements”