Search found 67 matches

by dlen
Wed Sep 21, 2016 12:00 pm
Forum: Modules/Add-Ons
Topic: [solved] TinyMCE:insert image fails with permissions problem
Replies: 0
Views: 845

[solved] TinyMCE:insert image fails with permissions problem

History: Had switched to prettyURLs and therefore copied the provided htaccess.txt into the .htaccess file. Action: Try to insert image via TinyMCE - modify/insert image - browse images. Result: Forbidden You don't have permission to access /modules/TinyMCE/responsive_filemanager/filemanager/dialog....
by dlen
Fri Sep 09, 2016 6:37 pm
Forum: CMSMS Core
Topic: cms_selflink dir='up' leads to very same page
Replies: 2
Views: 840

cms_selflink dir='up' leads to very same page

Hi there, my intention is to take the user back to the parent page with {cms_selflink dir='up' image='uploads/images/allgemein/beenden-kreuz.svg' imageonly=1} . problem is, the url produced is not that of the parent page but of the page containing the link, so it's a link to itself. cmsms v2.1.5 Any...
by dlen
Mon Sep 05, 2016 10:25 pm
Forum: [locked] Installation, Setup and Upgrade
Topic: what works and doesn't with smarty scopes
Replies: 2
Views: 1397

Re: what works and doesn't with smarty scopes

thanks for the valuable link.
by dlen
Mon Sep 05, 2016 5:01 pm
Forum: [locked] Installation, Setup and Upgrade
Topic: what works and doesn't with smarty scopes
Replies: 2
Views: 1397

what works and doesn't with smarty scopes

Hi, i write this down to try to help others with the same problem. Situation: Assigned values to smarty variables in template file above the <__html> tag. Used always the attribute "scope=global". Some variables could be used from down below the </__body> tag, while others couldn't. Turned out, that...
by dlen
Fri Sep 02, 2016 6:13 pm
Forum: Modules/Add-Ons
Topic: lost in a maze around cgsimple::get_root_alias()...
Replies: 5
Views: 1626

Re: lost in a maze around cgsimple::get_root_alias()...

Thanks very much, I got this sorted out. Almost. Now struggeling with smarty scopes. But this will be another post, if any.
by dlen
Fri Sep 02, 2016 10:54 am
Forum: Modules/Add-Ons
Topic: lost in a maze around cgsimple::get_root_alias()...
Replies: 5
Views: 1626

Re: lost in a maze around cgsimple::get_root_alias()...

Wow, it did help indeed. I was oviously using a "$" too many. Apparently, within Smarty module names are not used with dollar-signs. Probably because the string is used "as is" to look up the object in the smarty parameter array. (Sorry, I am not in the "smarty zone" since a couple of month...these ...
by dlen
Fri Sep 02, 2016 1:04 am
Forum: Modules/Add-Ons
Topic: lost in a maze around cgsimple::get_root_alias()...
Replies: 5
Views: 1626

lost in a maze around cgsimple::get_root_alias()...

Hello forists, I just upgraded a site from cmsms 1.12.1 to 2.1.5. I found out, that i had to replace {$page_lang = substr($cgsimple->get_root_alias(),0,2)} with {$page_lang = substr($cgsimple::get_root_alias(),0,2)} But this is not the end. When I just cleared the cache, I get the following error me...
by dlen
Tue May 24, 2016 10:06 pm
Forum: CMSMS Core
Topic: simple_navigation makes sectionheaders, separators clickable
Replies: 1
Views: 876

Re: simple_navigation makes sectionheaders, separators click

The code i posted above is wrong, it must be

Code: Select all

    {if $node->url and !$node->current and $node->type != 'separator' and $node->type != 'sectionheader'}
      {assign var='writelink' value=true}
    {/if}
instead.
by dlen
Tue May 24, 2016 1:46 pm
Forum: CMSMS Core
Topic: simple_navigation makes sectionheaders, separators clickable
Replies: 1
Views: 876

simple_navigation makes sectionheaders, separators clickable

Hi there, this is actually a kind of bug report about the template simple_navigation shipped with 2.x. Action: make a page "separator" or "sectionheader". Expected result: menu item is not clickable, allows to open submenus though, in the case of "separators". Experienced result:menu item is clickab...
by dlen
Tue May 24, 2016 1:33 pm
Forum: CMSMS Core
Topic: Navigator Breadcrumbs default template enhancement
Replies: 3
Views: 1830

Re: Navigator Breadcrumbs default template enhancement

Is there a bug report / enhancement request page for such things?

Or are they regularly read by the developers here and taken into account?
by dlen
Thu May 19, 2016 1:59 pm
Forum: CMSMS Core
Topic: Navigator Breadcrumbs default template enhancement
Replies: 3
Views: 1830

Navigator Breadcrumbs default template enhancement

Hi there, currently (2.1.3) you find there the following code, which conditionally puts out a start text: {if isset($starttext)}{$starttext}: {/if} I noticed, that this puts out - the default start text if no parameter start_text is given - a colon if it is given, but empty. So you have no way ...
by dlen
Thu May 19, 2016 1:22 pm
Forum: [locked] Installation, Setup and Upgrade
Topic: [solved] 2.1.3: > extensions >tags - page gives 500
Replies: 5
Views: 2461

Re: 2.1.3: > extensions >tags - page gives 500 (internal ser

Wonder why it was in the download in the first place ...

Thanks anyway for the quick answer. It worked. Interestingly , just renaming the hacked version into function.get_template_vars_hacked.php did not work, I had to delete it, as you wrote.
by dlen
Thu May 19, 2016 12:32 pm
Forum: [locked] Installation, Setup and Upgrade
Topic: [solved] 2.1.3: > extensions >tags - page gives 500
Replies: 5
Views: 2461

[solved] 2.1.3: > extensions >tags - page gives 500

I wanted to check some built in tags and clicked > extensions > tags and got a 500 - error. I switched config['debug'] to true and got: Cannot redeclare smarty_cms_function_get_template_vars() (previously declared in /var/www/web411/html/cmsms/plugins/function.get_template_vars_orig.php:19) in /var/...
by dlen
Mon Jan 11, 2016 7:27 pm
Forum: The Lounge
Topic: most Gallery display functions not working in simplex theme
Replies: 6
Views: 3000

Re: most Gallery display functions not working in simplex th

Thanks both for your answers.

As i see now, the info about jquery beeing loaded twice is existing on http://wiki.cmsms.nl/index.php/Gallery.

Sometimes testing it out for 2 hours can save 20 minutes of reading documentation ;-).
by dlen
Sat Jan 09, 2016 9:54 pm
Forum: The Lounge
Topic: most Gallery display functions not working in simplex theme
Replies: 6
Views: 3000

Re: most Gallery display functions not working in simplex th

Thanks, Jos, for your reply.

apart from fancybox, the problem with loading jQuery twice seems to me a more profound one, affecting many modules.

Is there a convention in CMSMS, how the loading of jQuery, and the initialisation of modules that use jQuery, should be organized?

Go to advanced search