Search found 1290 matches

by DIGI3
Mon Dec 06, 2021 5:06 pm
Forum: CMSMS Core
Topic: CMSMS\Database\DatabaseConnectionException
Replies: 3
Views: 60

Re: CMSMS\Database\DatabaseConnectionException

I'm pretty sure the only things it could be is incorrect settings in the config.php file or the user not having access to the database. Some hosts put the database on a different server so the defaults aren't always appropriate. Often clearing the cache (manually, if necessary) will fix issues after...
by DIGI3
Sat Dec 04, 2021 3:44 pm
Forum: General Discussion
Topic: Start learning CMS MS
Replies: 9
Views: 3041

Re: Start learning CMS MS

Thanks, the typos have been fixed.
by DIGI3
Wed Dec 01, 2021 4:29 pm
Forum: CMSMS Core
Topic: Error messages displayed at top of website
Replies: 1
Views: 59

Re: Error messages displayed at top of website

Your host likely either changed a php setting (display_errors) or upgraded PHP, or both. Short term fix you can set the errors to not display. The method for this can vary based on your server configuration and php version, but usually it's one of editing php.ini or .user.ini, either directly or thr...
by DIGI3
Tue Nov 30, 2021 1:29 am
Forum: Modules/Add-Ons
Topic: LISE Instance Item dropdown with blank
Replies: 5
Views: 131

Re: LISE Instance Item dropdown with blank

Probably better to edit the .tpl LISE is using for that and put it in module_custom. A UDT would work too, but yeah would take some figuring out.
by DIGI3
Mon Nov 29, 2021 11:18 pm
Forum: Modules/Add-Ons
Topic: LISE Instance Item dropdown with blank
Replies: 5
Views: 131

Re: LISE Instance Item dropdown with blank

For a temporary workaround, create a dummy LISE entry called "none" (or similar) in your other module, then exclude it from frontend display in your template or module tag.
by DIGI3
Fri Nov 26, 2021 3:51 pm
Forum: CMSMS Core
Topic: Slow admin area
Replies: 9
Views: 463

Re: Slow admin area

Software doesn't just stop working or get slower because it's over 1 year old. What version of PHP are you running? What happens if you go back a version?
by DIGI3
Sun Nov 21, 2021 2:50 pm
Forum: Tips and Tricks
Topic: Page background image
Replies: 5
Views: 231

Re: Page background image

Take a look in the help file under content_image, it should give you an idea how to add an image picker to a page. There are also third-party modules such as JMFilePicker and ECB2 which offer other options. {$page_alias} is just the variable the alias of the page is stored in, so you can use it anyw...
by DIGI3
Sat Nov 20, 2021 3:13 pm
Forum: Modules/Add-Ons
Topic: Captcha plugin
Replies: 2
Views: 161

Re: Captcha plugin

It works fine in PHP 7.4, just set up your error reporting to ignore notices on a production site.

The module is still supported by jomorg, he's just a bit behind on updates.
by DIGI3
Sat Nov 20, 2021 3:10 pm
Forum: Tips and Tricks
Topic: Page background image
Replies: 5
Views: 231

Re: Page background image

Unless your developer set up an option to choose a background image per page in the content editor, it will likely require some changes to the code. TInyMCE can't really change anything outside of the specific block you're editing. One option is to give every page a unique CSS class or ID, which cou...
by DIGI3
Thu Nov 18, 2021 2:40 pm
Forum: CMSMS Core
Topic: Slow admin area
Replies: 9
Views: 463

Re: Slow admin area

I've had this issue with a few hosts adding a limit on the number of processes/iops. Sometimes there are clues in the error or access logs, like DENY due to rate limit etc. If you have cPanel or similar you may be able to see the limits, typically the problems start occurring if they limit it to 100...
by DIGI3
Wed Nov 17, 2021 7:08 pm
Forum: Modules/Add-Ons
Topic: SmartForms jump to back after Submit
Replies: 2
Views: 87

Re: SmartForms jump to back after Submit

Add an anchor where you want it to scroll to, then add javascript in the "Smarty template for the final message to display to the user" field that scrolls to said anchor. If you use CMSExt then you can {js_add} here, but you can also just use inline script tags.
by DIGI3
Tue Nov 16, 2021 3:21 pm
Forum: Modules/Add-Ons
Topic: LISE date picker triggering URL load
Replies: 3
Views: 146

Re: LISE date picker triggering URL load

The console reveals more, it looks like it's trying to use a function that was removed from jQueryUI some time ago (datepicker.log): Uncaught TypeError: $.datepicker.log is not a function at Timepicker._parseTime (jquery-ui-timepicker-addon.js:310) at Timepicker._addTimePicker (jquery-ui-timepicker-...
by DIGI3
Sun Nov 14, 2021 11:34 pm
Forum: Modules/Add-Ons
Topic: uploads/Products/ changes to uploads/_products/
Replies: 2
Views: 156

Re: uploads/Products/ changes to uploads/_products/

At some point the dev switched this to use the new path for the uploads, presumably so users with File Manager access wouldn't delete product images (directories starting with an underscore are hidden from File Manager). I haven't read through all of the release notes to confirm, but that would be m...
by DIGI3
Fri Oct 29, 2021 5:02 pm
Forum: Modules/Add-Ons
Topic: Using Smart Image within News template - not working
Replies: 5
Views: 296

Re: Using Smart Image within News template - not working

It looks like filters don't work, but they do in cgsi so probably just a forking bug. The max_width and max_height parameters do work, so you might be able to use those for now until a patch is released. I have filed a BR: http://dev.cmsmadesimple.org/bug/view/12491

Go to advanced search