Search found 61 matches

by Sendlingur
Wed Jan 20, 2021 11:33 am
Forum: CMSMS Core
Topic: lang=0 not working when using cms_selflink dir
Replies: 1
Views: 253

lang=0 not working when using cms_selflink dir

I'm using {cms_selflink dir } in a template to display next/prev links. The documentation says to get rid of the "Previous page:" and "Next page:" you should use lang=0, but that's not working at all. Here is what it says in the docs "lang - Display link-labels ("Next Page"/"Previous Page") in diffe...
by Sendlingur
Wed Sep 30, 2020 5:03 pm
Forum: CMSMS Core
Topic: I there a way to submit News article with no content?
Replies: 2
Views: 313

I there a way to submit News article with no content?

Hi, all

I've been trying to submit a News article without content. It has content but for articles in this specific category I use custom fields for the content.

Obviously I always get the "No content given" message and can't submit the article.

Is there away around this?
by Sendlingur
Wed Sep 30, 2020 4:27 pm
Forum: CMSMS Core
Topic: Restrict user from news module categories
Replies: 2
Views: 280

Re: Restrict user from news module categories

Thank you, I had thought of the template hack solution, maybe I'll use it :D
by Sendlingur
Mon Sep 28, 2020 3:39 pm
Forum: CMSMS Core
Topic: Restrict user from news module categories
Replies: 2
Views: 280

Restrict user from news module categories

I was thinking.... I have few back-end users which can add/edit articles in the News module. The News module has 8 categories . Is it somehow possible to restrict user access to some categories. For example user 1 can add/edit articles in all categories but user 2 can only add/edit articles in categ...
by Sendlingur
Wed May 13, 2020 11:20 am
Forum: CMSMS Core
Topic: changing custom input field to text Area field - News Module
Replies: 1
Views: 573

changing custom input field to text Area field - News Module

I've couple of custom input fields that needs to be changed to Text Area field. Is there a way to do it without deleting the existing input and lose its data? The only solution I know is to delete the existing input field and create new Text area with the same name. But that deletes the existing dat...
by Sendlingur
Tue Feb 04, 2020 10:55 am
Forum: CMSMS Core
Topic: Customizing news module backend with Jquery
Replies: 2
Views: 688

Customizing news module backend with Jquery

I'm having a slight problem with my news module back-end. I've been customizing the "editarticle.tpl" so it will show/hide custom fields upon category selection. It works fine when I create a new article in that specific category.(then the custom fields appears) But if I want to edit the article, th...
by Sendlingur
Thu Oct 24, 2019 11:25 am
Forum: CMSMS Core
Topic: Link from content page to news article?
Replies: 1
Views: 610

Link from content page to news article?

Hi all Is it possible to link to a specific news article from the content page editor? As things are in my setup it is only possible to link to another content page but not a specific news article. I was thinking about if the back end user is writing a content to a content page and wants to have a l...
by Sendlingur
Wed Oct 16, 2019 11:02 am
Forum: CMSMS Core
Topic: Advice on how to read contents of .txt file to template
Replies: 6
Views: 1060

Re: Advice on how to read contents of .txt file to template

Thanks all, I decided to just go with the {gallery} for this. I'll try your solutions on future projects.
by Sendlingur
Wed Oct 16, 2019 10:37 am
Forum: CMSMS Core
Topic: Using {anchor} in news module detail template
Replies: 0
Views: 549

Using {anchor} in news module detail template

In my news detail template I've an "slidebar" which contains links to various sections in the news detail template. I've been spending lots of time to get the {anchor} tag to work. But the link always goes to the this path (https://mypage.com/index.php?page=mainpage#section03) but never goes to corr...
by Sendlingur
Thu Oct 10, 2019 4:43 pm
Forum: CMSMS Core
Topic: Advice on how to read contents of .txt file to template
Replies: 6
Views: 1060

Re: Advice on how to read contents of .txt file to template

I've been trying to make this work to get the .txt file contents, but without luck.

Code: Select all

{uploads_url}/images/{$entry->Picfolder}/*.txt"|file_get_contents|parse_str:$result}
I'm still pretty stuck here :)
by Sendlingur
Thu Oct 10, 2019 11:31 am
Forum: CMSMS Core
Topic: Advice on how to read contents of .txt file to template
Replies: 6
Views: 1060

Re: Advice on how to read contents of .txt file to template

Jos wrote:Seems to me you are rebuilding all the functionality the Gallery module has to offer :-X ;)

Haha... I quess it is for the purpose of learning :)
by Sendlingur
Thu Oct 10, 2019 11:08 am
Forum: CMSMS Core
Topic: unable to access image folder
Replies: 4
Views: 888

Re: unable to access image folder

Thanks Jos for your help
This works but I ended up using another solution which gives the same result.
by Sendlingur
Thu Oct 10, 2019 11:05 am
Forum: CMSMS Core
Topic: Advice on how to read contents of .txt file to template
Replies: 6
Views: 1060

Advice on how to read contents of .txt file to template

Hi I'm looping through an image folder and displaying the images in a bootstrap carousel in the news detail template. That is working very well My problem is that there should be a caption and a text for each image. My solution is to put a .txt file which contains caption contents for each image in ...
by Sendlingur
Wed Oct 09, 2019 1:38 pm
Forum: CMSMS Core
Topic: using {$entry->Picfolder} in an {assign} not working?
Replies: 3
Views: 694

Re: using {$entry->Picfolder} in an {assign} not working?

I figured it out , I had to add " |glob " to the end of the string.

thanks again Rolf for pointing out the "".
by Sendlingur
Wed Oct 09, 2019 1:10 pm
Forum: CMSMS Core
Topic: using {$entry->Picfolder} in an {assign} not working?
Replies: 3
Views: 694

Re: using {$entry->Picfolder} in an {assign} not working?

Thanks Rolf of course it is double quotes :). The path is right now. But for some reason it looks like this
<img src="https://mypage.com/uploads/images/projectx/*.jpg" width="600" height="600" alt="">

it is reading the jpg as " *.jpg ".

Why is that?

Go to advanced search