Search found 448 matches

by nervino
Thu Jun 29, 2017 7:43 am
Forum: CMSMS Core
Topic: Internal: User key not found in session.
Replies: 13
Views: 2917

Re: Internal: User key not found in session.

I've made two tests but I couldn't reproduce the problem. First test: 1) Installed 2.2.1 2) Installed custom module 3) Visited the page that calls custom module All works fine Second test (condition similar to the one in which problems had arisen): 1) Installed 2.1.6 2) Installed custom module 3) cl...
by nervino
Tue Jun 27, 2017 3:54 pm
Forum: CMSMS Core
Topic: Internal: User key not found in session.
Replies: 13
Views: 2917

Re: Internal: User key not found in session.

Thank you scooper.
Today the page is displaying right also when I'm logged in admin.
I agree with you, it must be some kind of session issue...
by nervino
Mon Jun 26, 2017 4:43 pm
Forum: CMSMS Core
Topic: Internal: User key not found in session.
Replies: 13
Views: 2917

Internal: User key not found in session.

Hello, after the upgrade from 2.1.6 to 2.2.1 I get this error when trying to visit a frontend page that call a custom module: Error: at line 138 in file /var/www/derenzi/lib/classes/internal/class.LoginOperations.php: Internal: User key not found in session. It seems related to login but the page is...
by nervino
Thu Feb 16, 2017 5:53 pm
Forum: Developers Discussion
Topic: Include .tpl template inside another
Replies: 3
Views: 2753

Re: Include .tpl template inside another

Thank you, Robert. It works but there's a weird behaviour: in cms page template I have: <div class="main_container">{content}... the included .tpl starts with: <div class="col-md-3 left_col"> the generated html output is: <div class="main_container"> <p></p> <div class="col-md-3 left_col"> I solved ...
by nervino
Thu Feb 16, 2017 2:24 pm
Forum: Developers Discussion
Topic: Include .tpl template inside another
Replies: 3
Views: 2753

Include .tpl template inside another

Hello,
I have a module with its .tpl templates; I want to include one of these templates inside another (both tempates are in "modules/MyModule/templates" dir). I tried with the smarty {include} without success.
Is it possible?

Thanks
by nervino
Fri Sep 30, 2016 2:02 pm
Forum: Modules/Add-Ons
Topic: Formbuilder and sending data to google analytics
Replies: 1
Views: 731

Formbuilder and sending data to google analytics

Hello, how can I send an event to Google with Formbuilder on form submit? What I need is that when the user submit the mail form, an event is sent to Google (i.e.: ga('send', 'event', 'form', 'submit', 'Info Request')). Is it possible or I have to track the event in another way, like redirecting the...
by nervino
Fri Aug 26, 2016 2:02 pm
Forum: Modules/Add-Ons
Topic: Disqus module and smarty variable problem
Replies: 0
Views: 620

Disqus module and smarty variable problem

Hello, I have installed the Disqus module but the smarty variables created in its action.default.php page are not printed in the tpl template. The variable is not empty (it is printed with php "echo"). I made a lot of attempts but I cannot figure out the reason. Any ideas..? thanks -----------------...
by nervino
Sun Jul 03, 2016 1:26 pm
Forum: The Lounge
Topic: The mysterious disappearance of solved posts
Replies: 5
Views: 1862

Re: The mysterious disappearance of solved posts

I've digged in the forum and I've found a post of mine (started on 2016 jun 21: http://forum.cmsmadesimple.org/viewtopic.php?f=3&t=75104 - see attachment) at page 151. Hence, I think that there must be a sort of an ORDER BY clause issue. The edit button is present as soon you make a post, than it di...
by nervino
Thu Jun 30, 2016 11:25 am
Forum: The Lounge
Topic: The mysterious disappearance of solved posts
Replies: 5
Views: 1862

The mysterious disappearance of solved posts

Hello everybody, I'm going to make a probably silly question: I've noticed that the option to edit a post in the forum is not present anymore, and checking the green check sign to accept an answer make the thread disappear from the forum list. In the Board preferences I couldn't find any new config ...
by nervino
Wed Jun 22, 2016 6:33 pm
Forum: [locked] Installation, Setup and Upgrade
Topic: Weird css error
Replies: 2
Views: 1731

Re: Weird css error

I think you are right, as usual. Thank you for the hint! (I discovered that the production server isn't an ubuntu 16.04 - as I took for granted - but a 14.04.4 version with upgraded versions of PHP and MySQL. The ubuntu 16.04 that I had installed in vmware has not the ONLY_FULL_GROUP_BY sql mode ena...
by nervino
Tue Jun 21, 2016 5:45 pm
Forum: [locked] Installation, Setup and Upgrade
Topic: Weird css error
Replies: 2
Views: 1731

Weird css error

Hello, I have uploaded a cmsms' 2.1.4 site from development environment to production server and I got this error in Design Manager => Stylesheets tab: SELECT SQL_CALC_FOUND_ROWS DISTINCT S.id FROM cms_layout_stylesheets S ORDER BY S.name ASC LIMIT 0, 100 -- Expression #1 of ORDER BY clause is not i...
by nervino
Wed Jun 08, 2016 11:04 am
Forum: [locked] Installation, Setup and Upgrade
Topic: cmsms-2.1.4-install.php redirect to home page
Replies: 5
Views: 3383

Re: cmsms-2.1.4-install.php redirect to home page

Yes, when I open http://www.example.com/cmsms-2.1.4-install.php I am redirected to http://www.example.com/cmsms-2.1.4-install.php/index.php but I see the site's home page, not the installer. I'll try to replicate the situation in a local vmware to see if there are differences... I'll post back the s...
by nervino
Wed Jun 08, 2016 6:47 am
Forum: [locked] Installation, Setup and Upgrade
Topic: cmsms-2.1.4-install.php redirect to home page
Replies: 5
Views: 3383

Re: cmsms-2.1.4-install.php redirect to home page

I put the "example.com" but the actual domain is different.

I removed the .htaccess completely and changed config.php to not to use mod_rewrite. The problem is still there and I can't figure out the reason..
by nervino
Tue Jun 07, 2016 3:24 pm
Forum: [locked] Installation, Setup and Upgrade
Topic: cmsms-2.1.4-install.php redirect to home page
Replies: 5
Views: 3383

cmsms-2.1.4-install.php redirect to home page

Hello, I'm trying to upgrade from cmsms 2.1.3 to 2.1.4 but when I launch the upgrade process I am redirected to the home page. (URL: http://www.example.com/cmsms-2.1.4-install.php/index.php). I have uploaded the installation phar via FTP in binary mode. Previous upgrade of the same site had no probl...
by nervino
Sun May 29, 2016 10:29 am
Forum: Developers Discussion
Topic: Accented characters in URL and 404 error
Replies: 1
Views: 1265

Accented characters in URL and 404 error

I've upgraded an old cmsms site (1.10) to cmsms 2.1.3. In this site I had a module where I handled pretty urls in this way: MyModule.module.php: function InitializeFrontend() { // All $this->RegisterRoute('/[MyModule\/(?P<IDart>[0-9-]+)_(?P<returnid>[0-9]+)_l(?P<filter_loc>[0-9]+)_t(?P<filter_tipo>[...

Go to advanced search