Search found 96 matches

by blackrain
Fri Jan 22, 2021 10:54 am
Forum: CMSMS Core
Topic: Mail Setting password Field length
Replies: 3
Views: 196

Re: Mail Setting password Field length

Hi @rotezecke, you are correct the limits are set in the siteprefs.tpl file in admin/templates. The html limit is set to 50 and this governs the accepted character length. The Db does not seem to constrain it as it is save as part of an array. Thanks for responding, I set the limit to 100 in the sit...
by blackrain
Thu Jan 21, 2021 5:01 pm
Forum: CMSMS Core
Topic: Mail Setting password Field length
Replies: 3
Views: 196

Mail Setting password Field length

I was asked the question, "what is the limit of the password field in the mail settings on CMSMS" I have to say, I don't know. can someone tell me the character limit in the password field, it looks like html limits it to 50 but not sure of that is just display limit.

Thanks
by blackrain
Wed Jan 06, 2021 12:42 pm
Forum: Modules/Add-Ons
Topic: Why would LISE add 455 to the url on only one instance
Replies: 1
Views: 76

Re: Why would LISE add 455 to the url on only one instance

I have found the reason.
It looks like the url constructor was incorrectly configured, so a default url was used, I fixed the url prefix and the url generation code in the LISE options, all seems to work fine and urls are now generation correctly without the /455 being added.
by blackrain
Wed Jan 06, 2021 12:06 pm
Forum: Modules/Add-Ons
Topic: Why would LISE add 455 to the url on only one instance
Replies: 1
Views: 76

Why would LISE add 455 to the url on only one instance

I have been using LISE for several years now and have recently created a new LISE instance to a website, the instance work much the same as any other LISE instance I have created. I have made 10 other LISE instances on theis site and all work well together without issues. however, the latest LISE in...
by blackrain
Sat Apr 04, 2020 8:58 am
Forum: Modules/Add-Ons
Topic: Uploads Module: stopped show frontend file when moved to new
Replies: 3
Views: 526

Re: Uploads Module: stopped show frontend file when moved to

@Rolf Config is correct and the rest of the cms works as expected it is just the Uploads module that is affected. @DIGI3 On the old server the Uploads module showed files on the frontend, they appear perfectly on the cms but do not render at all on the frontend. I have tried to see the array using: ...
by blackrain
Fri Apr 03, 2020 2:29 pm
Forum: Modules/Add-Ons
Topic: Uploads Module: stopped show frontend file when moved to new
Replies: 3
Views: 526

Uploads Module: stopped show frontend file when moved to new

Hi, I recently moved a site to a new server, The site is running cmsms 1.12.2 and will need to continue doing so for a short time until the client agrees to the upgrade. however, the module Uploads has stopped working and I have no idea why this would be, I don't know if it need a specific php exten...
by blackrain
Mon Mar 02, 2020 11:38 am
Forum: CMSMS Core
Topic: Error in /lib/classes/class.CmsRoute.php on line 251
Replies: 1
Views: 449

Re: Error in /lib/classes/class.CmsRoute.php on line 251

This is the related section of the class file. 238 { 239 $this->_results = null; 240 if( (isset($this->_data['absolute']) && $this->_data['absolute']) || $exact ) { 241 $a = trim($this->_data['term']); 242 $a = trim($a,'/'); 243 $b = trim($str); 244 $b = trim($b,'/'); 245 246 if( !strcasecmp($a,$b) ...
by blackrain
Mon Mar 02, 2020 10:20 am
Forum: CMSMS Core
Topic: Error in /lib/classes/class.CmsRoute.php on line 251
Replies: 1
Views: 449

Error in /lib/classes/class.CmsRoute.php on line 251

PHP Warning: preg_match(): Unknown modifier 'n' in /lib/classes/class.CmsRoute.php on line 251

I have got this error occurring on my site. I have no idea why this is now an issue but it keeps coming up.

any thoughts.

I am running php 5.6.40 and nothing has changed except this error.

thanks
by blackrain
Wed Feb 26, 2020 11:19 am
Forum: Modules/Add-Ons
Topic: SMTP connect() Failure for CMSMailer
Replies: 2
Views: 526

Re: SMTP connect() Failure for CMSMailer

It turns out that the issue is with the hosing provider and a server update that has killed something on the server, not ver forthcoming with what was broken and why, but at least it is not CMSMS that is causing the issue.
by blackrain
Wed Feb 26, 2020 10:22 am
Forum: Modules/Add-Ons
Topic: Server setup for CMSMS
Replies: 1
Views: 420

Server setup for CMSMS

I am upgrading my server to php7.2 and find that some of the modules stop working, I have noticed that mcrypt is no longer available with php7.2 but can be added. Is it needed anymore and what is needed for cmsms to run properly with the modules I have installed. I feel I may be missing something im...
by blackrain
Thu Feb 20, 2020 11:11 am
Forum: Modules/Add-Ons
Topic: Products: How can I select a product inside CMS content page
Replies: 3
Views: 564

Re: Products: How can I select a product inside CMS content

Hi @DIGI3

The cms page shows "An invalid curpage was passed toProducts\DisplayableProduct::__construct" in the dropdown. not sure why this is happening.
by blackrain
Wed Feb 19, 2020 2:48 pm
Forum: Modules/Add-Ons
Topic: SMTP connect() Failure for CMSMailer
Replies: 2
Views: 526

SMTP connect() Failure for CMSMailer

For some reason the CMSMailer can no longer allow mail to be sent via SMTP. I have checked the settings on the CMS and they are correct. I have also checked using a SMTPer service external from the CMS and it works as expected. I have tried using mail() and sendmail() and neither work direct from th...
by blackrain
Wed Feb 19, 2020 2:42 pm
Forum: Modules/Add-Ons
Topic: Products: How can I select a product inside CMS content page
Replies: 3
Views: 564

Products: How can I select a product inside CMS content page

I am trying to find a way to allow users to select a product from the Product module and add it to a page, either a dropdown or multi-select is adequate.

Obviously if there is way to see image of product that would e helpful.

many thanks

Mark
by blackrain
Wed Dec 04, 2019 11:01 am
Forum: Modules/Add-Ons
Topic: Cart2 Ajax calls
Replies: 4
Views: 888

Re: Cart2 Ajax calls

@calguy1000

Is there a way of the Cart2 module exposing the sku's currently held in the cart so that on load I can tell the page to scroll the sku id I have assigned to the product widget? this may be a solution I could explore to solve my issue in the short term?

Thanks
by blackrain
Wed Dec 04, 2019 9:07 am
Forum: Modules/Add-Ons
Topic: Cart2 Ajax calls
Replies: 4
Views: 888

Cart2 Ajax calls

I am trying to get the Cart2 module to perform an ajax request rather than submitting the page.

I am using javascript to display that an item is added to the basket. unfortunately the page refreshes and the javascript instance is lost.

any thoughts welcome


Thanks

Go to advanced search