• twitter image
  • facebook image
  • youtube image
  • linkedin image
Language: CMS Made Simple Czech CMS Made Simple France CMS Made Simple Spain CMS Made Simple Hungary CMS Made Simple Russia CMS Made Simple Netherlands

All times are UTC




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: Help! CGJobMgr no longer working
PostPosted: Mon Feb 25, 2013 2:12 pm 
Offline
Forum Members
Forum Members

Joined: Sun Sep 20, 2009 1:22 pm
Posts: 22
Hi folks,

I'm struggling with CGJobMgr after everything was working fine, and I can't think of what next to debug.

CGJobMgr 1.2.13
NMS 2.7.2
(all modules up-to-date)

When I try and run the job manager URL (via curl to test), I get:
Code:
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<__html><head>
<title>404 Not Found</title>
</head></__body>
<h1>Not Found</h1>
<p>The requested URL was not found on this server.</p>
<__body></__html>


I've inserted a "echo ...; die;" at the top of action.process.php in the CGJobMgr directory, and it isn't getting called. However, if I set config['debug']=true, I'm also not getting the debug output. (The site is live, so I'm trying not to get too exotic in the diagnostic messages).

I have an exact duplicate of the site (including DB) on my local machine, and the problem doesn't exist.

I thought it might be the .htaccess, but I'm using the stock one provided, so I don't think that's it.

I've cleared the cache, and rebuilt the routes, but that didn't seem to change things.

Can anybody think of a way to call that action manually? I tried creating a pages with
Quote:
{CGJobMgr action="process"}
on it, but no luck.

Can anybody think of some next steps to try? I've never seen anything like this


Top
 Profile  
 
 Post subject: Re: Help! CGJobMgr no longer working
PostPosted: Mon Feb 25, 2013 3:16 pm 
Offline
Dev Team Member
Dev Team Member

Joined: Mon Nov 28, 2011 9:29 am
Posts: 1627
If you get a 404 it normally means you try to call a file or directory that does not exist.

As simple as that.

Trying to debug a non-existent page or altering a php file which never gets called (because non existent files can not call anything).

I would have a look at the url and the webservers error log.


Top
 Profile  
 
 Post subject: Re: Help! CGJobMgr no longer working
PostPosted: Mon Feb 25, 2013 4:44 pm 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Tue Oct 19, 2004 6:44 pm
Posts: 7132
Location: Fernie British Columbia, Canada
If CGJobMgr worked on the site once, and all of a sudden does not. Then I would suspect either you changed something with the config.php/.htaccess OR your host changed something.

_________________
Follow me on twitter
--
if you can't bother explaining your problem well, you shouldn't expect much in the way of assistance.
----------------
Don't make me angry..... you won't like me when I'm angry....


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Arvixe - A CMSMS Partner