• twitter image
  • facebook image
  • youtube image
  • linkedin image
Language: CMS Made Simple Czech CMS Made Simple France CMS Made Simple Spain CMS Made Simple Hungary CMS Made Simple Russia CMS Made Simple Netherlands

All times are UTC




Post new topic Reply to topic  [ 6 posts ] 
Author Message
 Post subject: Service Desk missing variable [bug listed - solved]
PostPosted: Wed Dec 05, 2012 8:43 pm 
Offline
Power Poster
Power Poster

Joined: Wed Aug 13, 2008 10:57 am
Posts: 672
Hi,

first,

when I define several statusses and I make email-messages then the {$startdate} variable returns nothing, I tried

"<p>{$startdate} - startdate - ..{$createdate|date_format} createdate </p>"

and it returns
"<p> - startdate - .. createdate </p>"

all other variables show up in the mail and it is ONLY when I change status and the status-template is used.


second,

I use more languages. For the first notification to the user, I send an email where the language is determined by
{if $lang == 'de_DE'} for german (for example).
If I change the status this will not work, does someone have a hint on how to solve it without defining the same status in three different languages?

Kind regards,
Jan


Last edited by janvl on Tue Dec 11, 2012 11:22 am, edited 1 time in total.

Top
 Profile  
 
 Post subject: Re: Service Desk missing variable
PostPosted: Thu Dec 06, 2012 6:54 pm 
Offline
Power Poster
Power Poster
User avatar

Joined: Fri Jun 08, 2007 7:29 pm
Posts: 897
Location: 's-Hertogenbosch, Netherlands
Jan,

I checked the code for the start date. It is a bug. Will be solved with the next release.

No idea how to handle the language settings.

Duketown


Top
 Profile  
 
 Post subject: Re: Service Desk missing variable
PostPosted: Thu Dec 06, 2012 8:40 pm 
Offline
Power Poster
Power Poster

Joined: Wed Aug 13, 2008 10:57 am
Posts: 672
Hi

thanks for notifying it is a bug, saves me searching.

I will solve the language-part by making a three-language E-Mail
when the status changes.

When it is ready I will see if my customers are willing to use it, frankly I have no idea if they will.

Kind regards,
Jan


Top
 Profile  
 
 Post subject: Re: Service Desk missing variable
PostPosted: Sat Dec 08, 2012 8:20 am 
Offline
Power Poster
Power Poster
User avatar

Joined: Fri Jun 08, 2007 7:29 pm
Posts: 897
Location: 's-Hertogenbosch, Netherlands
Jan,

With regards to the mail to the incident raiser, you would need to know in which language the person would like to communicate in. What was your idea for that. It seems like a field from FEU (since there the incident raisers are located, at least their info).
Sounds by the way as a MLE solution that you are looking for. I've not seen a module (I've not seen them all) that has language related mail settings.
For now multiple statusses (with the correct language being used on the mail) seems to be a solution, but I agree it is an it solution and not very handy for the end user.

Duketown


Top
 Profile  
 
 Post subject: Re: Service Desk missing variable
PostPosted: Sat Dec 08, 2012 9:30 am 
Offline
Power Poster
Power Poster

Joined: Wed Aug 13, 2008 10:57 am
Posts: 672
Hi,

I use Rolf's solution for multilanguage. This gives the opportunity to handle most language items.

For me the situation is no big deal, status-notification is short anyway. The "problem" can be found in more modules using mail but most will still be usable.

BTW the site that I want to use (test) Servicedesk for is my own, http://www.stajl.at
Depending if my customers want to use it I might upgrade to gold but I have no idea if they will, this is austia and very conservative.

Kind regards,
Jan


Top
 Profile  
 
 Post subject: Re: Service Desk missing variable [bug listed - solved]
PostPosted: Tue Dec 11, 2012 11:26 am 
Offline
Power Poster
Power Poster

Joined: Wed Aug 13, 2008 10:57 am
Posts: 672
Considering Multilanguage,

The confirmation is arranged as follows.

After submitting the service-request you jump to a page where the browserlanguage is checked with the udt "browser_language", see Rolf"s article on multilanguage CMS.
There I do a redirect to language specific pages, no highlight but functional.

Kind regards,
Jan


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Arvixe - A CMSMS Partner