• twitter image
  • facebook image
  • youtube image
  • linkedin image
Language: CMS Made Simple Czech CMS Made Simple France CMS Made Simple Spain CMS Made Simple Hungary CMS Made Simple Russia CMS Made Simple Netherlands

All times are UTC




Post new topic Reply to topic  [ 12 posts ] 
Author Message
 Post subject: Search module 1.54 problem, no results display on page desig
PostPosted: Fri Nov 30, 2012 4:50 pm 
Offline
Forum Members
Forum Members

Joined: Wed Aug 01, 2012 7:46 pm
Posts: 92
Greetings, I cant seem to get the search to point to a specific search page for search results. The only way I can get results to post is on the index page (which I am assuming is referencing the default in the system)

I referred to this document on proper instructions yet no results load when I specify a page for results. Its just a blank page

http://docs.cmsmadesimple.org/modules/core/search

My Code for the search script.

<!--Search -->
<div id=search>{search resultpage='search-results'}</div>
<!--End Search -->

Any Ideas?


CMS Version 1.10.3


Installed Modules
CMSMailer 2.0.2
CMSPrinting 1.0
FileManager 1.2.0
MenuManager 1.7.7
MicroTiny 1.1.1
ModuleManager 1.5.3
News 2.12.3
Search 1.5.4
ThemeManager 1.1.4
FormBuilder 0.7.3
Captcha 0.4.5
jQuery 1.2.0
CGExtensions 1.31
ExtendedTools 1.3.3
Analytics 1.2.2


Top
 Profile  
 
 Post subject: Re: Search module 1.54 problem, no results display on page d
PostPosted: Sat Dec 01, 2012 10:18 am 
Offline
Support Guru
Support Guru
User avatar

Joined: Wed Sep 05, 2007 8:03 pm
Posts: 3814
Location: The Netherlands
does the page with alias 'search-results' actually exist?

_________________


Top
 Profile  
 
 Post subject: Re: Search module 1.54 problem, no results display on page d
PostPosted: Mon Dec 03, 2012 2:23 pm 
Offline
Forum Members
Forum Members

Joined: Wed Aug 01, 2012 7:46 pm
Posts: 92
it does exist, and it will point to the correct page but will show ZERO results. Like I said it will only post results to the index page, I have unistalled it and re-installed the 1.54v and it does the same problem. I dont know how to address this issue but its a real problem.

any thoughts?


Top
 Profile  
 
 Post subject: Re: Search module 1.54 problem, no results display on page d
PostPosted: Wed Dec 05, 2012 9:55 pm 
Offline
Forum Members
Forum Members

Joined: Wed Aug 01, 2012 7:46 pm
Posts: 92
can someone please help me with this? is this a common problem????? I need to get this resolved ASAP!!


Top
 Profile  
 
 Post subject: Re: Search module 1.54 problem, no results display on page d
PostPosted: Thu Dec 06, 2012 1:54 am 
Offline
Power Poster
Power Poster

Joined: Fri Mar 30, 2007 2:28 am
Posts: 975
Location: London
Try search as {Search

What version of CMS ?


Top
 Profile  
 
 Post subject: Re: Search module 1.54 problem, no results display on page d
PostPosted: Thu Dec 06, 2012 9:26 pm 
Offline
Forum Members
Forum Members

Joined: Wed Aug 01, 2012 7:46 pm
Posts: 92
That did not work, its just listed the text and no form.

{Search}

"CMS Made Simple™ 1.10.3 "Hyacinthe""

here is an example if you look it will not work on any internal pages, even when specified. the only way it works is on index.

http://www.atcomm.com/Support

please help I need to get this resolved!


Top
 Profile  
 
 Post subject: Re: Search module 1.54 problem, no results display on page d
PostPosted: Thu Dec 06, 2012 9:37 pm 
Offline
Power Poster
Power Poster

Joined: Fri Mar 30, 2007 2:28 am
Posts: 975
Location: London
Code:
{search resultpage='search-results'}


Works fine for me in 1.10.3 on all the sites I run.

PM me if you would like me to take a look.


Top
 Profile  
 
 Post subject: Re: Search module 1.54 problem, no results display on page d
PostPosted: Thu Dec 06, 2012 9:46 pm 
Offline
Power Poster
Power Poster

Joined: Fri Mar 30, 2007 2:28 am
Posts: 975
Location: London
In mine the URL after submission is

search-results/?mact=Search%2Ccntnt01%2Cdosearch%2C0&cntnt01returnid=73&cntnt01searchinput=coffee&x=11&y=14&cntnt01origreturnid=63

Yours is

products/?mact=Search%252Ccntnt01%252Cdosearch%252C0&cntnt01returnid=62&cntnt01searchinput=solutions&submit=Submit

So obviously it is keeping on the same page and not including the cntnt01origreturnid variable

Have you tried setting the method as post. Also post your .htaccess file here.

Also switch on debug in the config and check the output.


Top
 Profile  
 
 Post subject: Re: Search module 1.54 problem, no results display on page d
PostPosted: Thu Dec 06, 2012 9:58 pm 
Offline
Power Poster
Power Poster

Joined: Fri Mar 30, 2007 2:28 am
Posts: 975
Location: London
Try this if not already in your config file

$config['page_extension'] = '/';


Top
 Profile  
 
 Post subject: Re: Search module 1.54 problem, no results display on page d
PostPosted: Fri Dec 07, 2012 3:27 pm 
Offline
Forum Members
Forum Members

Joined: Wed Aug 01, 2012 7:46 pm
Posts: 92
applejack wrote:
Try this if not already in your config file

$config['page_extension'] = '/';



THAT WORKED! THANKS!


Top
 Profile  
 
 Post subject: Re: Search module 1.54 problem, no results display on page d
PostPosted: Fri Dec 07, 2012 3:46 pm 
Offline
Power Poster
Power Poster

Joined: Fri Mar 30, 2007 2:28 am
Posts: 975
Location: London
Good after looking at your source code I thought that might be the issue.


Top
 Profile  
 
 Post subject: Re: Search module 1.54 problem, no results display on page d
PostPosted: Tue Jan 29, 2013 8:56 pm 
Offline
Administrator
Administrator
User avatar

Joined: Thu Mar 09, 2006 5:32 am
Posts: 12302
Location: Arizona
If you are using pretty URLs it is always a good idea to use a real extension, .html, .php, etc., / is not an extension...

_________________
Extensions » Modules/Tags click the name of the module/tag or Help to the right to get its parameters.
Right click and view source is a great way to see what you have to work with.
Check ver. CMSMS, PHP, server OS, in System Information page.
Default content http://multiintech.com/defaultcontent/
People are Wonderful
Business is Great
Life is Terrific
Ever wonder what happened to the Album module? Well it is alive and well.
http://album.multiintech.com/
Image


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 12 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
A2 Hosting