• twitter image
  • facebook image
  • youtube image
  • linkedin image
Language: CMS Made Simple Czech CMS Made Simple France CMS Made Simple Spain CMS Made Simple Hungary CMS Made Simple Russia CMS Made Simple Netherlands

All times are UTC




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: [Solved]Problem with CGUserDirectory and CGBlog
PostPosted: Tue Nov 20, 2012 10:43 am 
Offline
New Member

Joined: Wed Jul 18, 2012 12:54 pm
Posts: 7
Hello everyone

I have some problems to have CGUserDirectory and CGBlog work together.

What I would like to have :

A menu in the website where I have a list of all frontend users, and when someone clicks on a user's name, the page with the news written by this user are displayed.
The news would be submitted via the frontend.

I managed to have the list of frontend users with CGUserDirectory. In the detail template of this module I simply put the CGBlog tag, specifying the author being the one that is visited.
Until there all is well.

But the problem is that when there is more than one news pages to display, the links to the next page doesn't work. It leads to an empty page...

When I try CGBlog with a specific author outside a CGUserDirectory template, everything works.

So I think that the problem comes from the interaction between the two modules, but I can't figure out what is going on...

Please help !!! :)

Thanks !

System info :
Quote:
----------------------------------------------
Cms Version: 1.11.3
Installed Modules:
CMSMailer: 5.2.1
CMSPrinting: 1.0.3
FileManager: 1.4.2
MenuManager: 1.8.4
MicroTiny: 1.2.4
ModuleManager: 1.5.5
News: 2.12.10
Search: 1.7.7
ThemeManager: 1.1.7
CGSimpleSmarty: 1.5.2
CGExtensions: 1.31.2
CGBlog: 1.9.8
FrontEndUsers: 1.21
CGUserDirectory: 1.3
CustomContent: 1.8.3

Config Information:
php_memory_limit:
process_whole_template:
output_compression:
max_upload_size: 64000000
url_rewriting: none
page_extension:
query_var: page
image_manipulation_prog: GD
auto_alias_content: true
locale:
default_encoding: utf-8
admin_encoding: utf-8
set_names: true

Php Information:
phpversion: 5.4.6
md5_function: On (Vrai)
gd_version: 2
tempnam_function: On (Vrai)
magic_quotes_runtime: Off (Faux)
E_STRICT: 2048
E_DEPRECATED: 8192
memory_limit: 128M
max_execution_time: 120
output_buffering: 4096
safe_mode: Off (Faux)
file_uploads: On (Vrai)
post_max_size: 64M
upload_max_filesize: 64M
session_save_path: /tmp (1777)
session_use_cookies: On (Vrai)
xml_function: On (Vrai)
xmlreader_class: On (Vrai)

Server Information:
Server Api: cgi-fcgi
Server Db Type: MySQL (mysqli)
Server Db Version: 5.1.49
Server Db Grants: Impossible de trouver un privilège "GRANT ALL". Cela peut signifier que vous pourriez avoir des problèmes pour installer ou retirer des modules, ou encore l 'ajout et la suppression d'éléments, y compris les pages.

----------------------------------------------


Last edited by shiningfm on Mon Nov 26, 2012 3:55 pm, edited 1 time in total.

Top
 Profile  
 
 Post subject: Re: Problem with CGUserDirectory and CGBlog
PostPosted: Thu Nov 22, 2012 12:44 pm 
Offline
New Member

Joined: Wed Jul 18, 2012 12:54 pm
Posts: 7
Does anyone have an idea ?

I'm stuck on this... Maybe I'm trying to solve my problem the wrong way. I mean if someone knows how I can handle this differently (instead of using CGDirectory and CGBlog) I'd be glad !

Or if I have to dive in the modules' code I'll do it but I don't know where to begin, I don't understand where the problem comes from...

Please please help !

Maybe I don't express myself very well (I'm french) so if not everything is comprehensible please tell me too and I'll try to explain better !

Thanks all


Top
 Profile  
 
 Post subject: Re: Problem with CGUserDirectory and CGBlog
PostPosted: Thu Nov 22, 2012 8:24 pm 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Tue Oct 19, 2004 6:44 pm
Posts: 6932
Location: Fernie British Columbia, Canada
Let me get this straight:

a: you are calling {CGUserDirectory} to get a summary list of all users, including a link to a detail view for each user.

b: inside the CGUserDirectory detail template you are calling something like:
{CGBlog author=$entry->userid limit=5} to generate a summary view of blog articles
by that author, with a specified pagelimit But there maybe say 20 or 30 articles by
that author.

c: The pagination links in the CGBlog summary template don't work

If this is the case then I wouldn't expect it to do what you want right now... but should not give you a white page either.

Have you checked the php error logs or the CMSMS admin log, for errors?

The CGBlog pagination links are not generated to be 'inline'. Which means that they 'should' generate a link to the content page itself, and the second, third, fourth page of the display will occupy the whole {content} area of the originating CMSMS page.

To modify this behaviour would involve adding a new parameter to CGBlog and modifying the CreateLink calls etc. in the php code that generates the CGBlog summary code.

_________________
Follow me on twitter
--
if you can't bother explaining your problem well, you shouldn't expect much in the way of assistance.
----------------
Don't make me angry..... you won't like me when I'm angry....


Top
 Profile  
 
 Post subject: Re: Problem with CGUserDirectory and CGBlog
PostPosted: Fri Nov 23, 2012 10:40 am 
Offline
New Member

Joined: Wed Jul 18, 2012 12:54 pm
Posts: 7
Thanks for the reply !
You understood the problem very well. Except for one point that I didn't explain correctly. I don't really get a white page, but a page with an empty content block.

You said :
Quote:
If this is the case then I wouldn't expect it to do what you want right now...

Do you know how I should do then ? I "just" want multiple frontend users to be able to manage news, and to have links to those individual links.


Top
 Profile  
 
 Post subject: Re: Problem with CGUserDirectory and CGBlog
PostPosted: Mon Nov 26, 2012 3:54 pm 
Offline
New Member

Joined: Wed Jul 18, 2012 12:54 pm
Posts: 7
If someone is interested, I used the function createFrontendLink in a UDT to solve the problem.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
A2 Hosting